Big Problem...

Discussion in 'Mac Basics and Help' started by mthaker, Dec 29, 2006.

  1. mthaker macrumors newbie

    Sep 8, 2006
    What up everyone, I have a MacBook 1.8gHz. When I turned it on today, it only displays a white screen and displays a flashing question mark ? inside of a small graphic of a folder.

    What does this mean? Is the OS damaged, or is it a hardware problem?

    Also, does anyone know the standard warranty for MacBooks?
  2. Shadow macrumors 68000


    Feb 17, 2006
    Keele, United Kingdom
    Sigh...we've been through this literally hundreds of times. Find your Mac OS X Install Disk, boot of it, goto Utilities-->Startup Disk and choose your internal HD and click restart.
  3. mthaker thread starter macrumors newbie

    Sep 8, 2006
    One Problem...

    Thanks Chris, but there's another problem: I already had a CD inside the CD-ROM before this happened, and the computer isn't letting me eject the CD.

    Uh oh...

  4. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Hold the mouse button down throughout the restart to force-eject a CD...

    The flashing ? means that the Mac cannot find a operating system.

    It may be from a number of causes, including hard drive failure or software corruption, but take it step by step. Do what Chris says. To force the machine to boot from the CD, hold the "c" key down through the boot process.

    Another maintenance thing you can do is, after booting from the OSX CD, go to the "installer" menu at the top, choose "Disk Utility", select your hard drive on the left, and choose "Repair Disk"

    Once you get running, have a try on the "Search" function here, and have a look at support section. These are fundamental skills.
  5. Warbrain macrumors 603


    Jun 28, 2004
    Chicago, IL
    I was going to say that, but I wasn't sure if it would still work if the OS wasn't loading correctly...
  6. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    It's an Open Firmware (EFI) command, so no OS has even to be present on the HD.
  7. mthaker thread starter macrumors newbie

    Sep 8, 2006
    Still no cigar

    I tried holding down the mouse button multiple times, but to no avail. The computer doesn't want to spit the CD out.

    I also tried pressing the mouse button repeatedly, but still nothing. I even tried the spacebar to see if it works, but nothing.

    Any other options..?
    Thanks guys.
  8. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    You have to keep the mouse button down from (re)boot until it spit sout.
    This can take up to about a minute. But keep it pressed!!!!

    Only the mouse button or trackpad button will do. Nothing else.

    This might work too (it did on PowerPC Macs):

    Boot while having the <OPTION> pressed, and you'll get the "os loader".
    Once you got that, maybe the <EJECT> key will work...?
  9. mthaker thread starter macrumors newbie

    Sep 8, 2006
    Tried these...

    Hey guys, I managed to get the CD out but when I pop in the Mac OS X CD, the Startup Disk option doesn't display any Internal HD; it only gives options for the DVD drive as the only available disk space.

    Does this mean the HD is permanently finished??! :(

  10. coday182 macrumors regular


    Jul 26, 2006
    Jamestown, IN
  11. fivetoadsloth macrumors 65816


    Aug 15, 2006
    THis doesnt look to good. Sounds like something died inside I think you are going to want to send it in to apple. Sorry. :(

Share This Page