Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

gregpod9

macrumors 6502
Original poster
Apr 27, 2007
306
91
1. My MBP M1 mouse cursor stays in one spot in Big Sur even though it looks like the cursor is working. Has anyone had this phantom non-functional mouse cursor that occurs randomly? For example out of 6 reboots, 1 reboot causes the random phantom non-functional mouse cursor. This happens with the touchpad and with my Logitech MX Anywhere 2S mouse.

2. Sometimes my Samsung M2835DW wireless printer sometimes prints symbols and does not print anything on pages thus leaving blank pages. My printer is using AirPrint drivers. Should I use the generic PCL Mac printer driver for now since there is no Big Sur drivers as of yet for my printer? This printing issue does not happen on my Windows laptop.
 

EvilCo_E

macrumors newbie
Sep 7, 2020
20
7
I just got a MBP M1 (16gb,1tb model) a few days ago and I have the same or similar mouse cursor issue. If I hit sleep it seems to fix itself but that's the only way it seems to fix itself for me when it happens, a restart or shut down does not always fix it.
Edit: Whenever this happens now and I put it to sleep it just crashes and stays on a black screen until I force it to shut down.

The cursor works on the login screen, but a few seconds after I log in it stops moving the cursor. Although the trackpad still works because I can actually click on things like the apple logo and things are still highlighted if I hover over them its just the image of the cursor that won't move. I didn't migrate my old install and I only installed Xcode and apple's "pro apps" so I'm not sure what's causing it but it is annoying.

I'm on Big Sur 11.1

Edit: I'm getting a replacement MacBook from Apple since a clean reinstall did not fix the problem. 2nd times the charm :p. Really strange issue
 
Last edited:

nastyame

macrumors newbie
Feb 5, 2021
1
0
I just got a MBP M1 (16gb,1tb model) a few days ago and I have the same or similar mouse cursor issue. If I hit sleep it seems to fix itself but that's the only way it seems to fix itself for me when it happens, a restart or shut down does not always fix it.
Edit: Whenever this happens now and I put it to sleep it just crashes and stays on a black screen until I force it to shut down.

The cursor works on the login screen, but a few seconds after I log in it stops moving the cursor. Although the trackpad still works because I can actually click on things like the apple logo and things are still highlighted if I hover over them its just the image of the cursor that won't move. I didn't migrate my old install and I only installed Xcode and apple's "pro apps" so I'm not sure what's causing it but it is annoying.

I'm on Big Sur 11.1

Edit: I'm getting a replacement MacBook from Apple since a clean reinstall did not fix the problem. 2nd times the charm :p. Really strange issue
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.