BIOS set-up on MacBook pro

Discussion in 'Windows, Linux & Others on the Mac' started by cdpilkington, Aug 15, 2006.

  1. cdpilkington macrumors member

    Apr 12, 2006
    I don't suppose any clever person knows if it's possible to access the BIOS setup screen on windows XP? I've been told it usually comes about by pressing/holding the "delete" key whilst windows is loading. However, I can't seem to get it to appear on the Macbook pro whilst I load. I need to disable hyperthreading in the BIOS to get something to work, and this seems to be the way to do it.
    Any ideas?
  2. ilkevinli macrumors 6502


    Apr 8, 2006
    There is no BIOS on Macs.

  3. Queso Suspended

    Mar 4, 2006
    Macs use Intel's Extensible Firmware Interface (EFI) to perform the same job as a BIOS. Intel have been trying to introduce this for years, but thanks to Microsoft dragging their feet, were unable to put it into any production units until Apple switched onto their processors. Therefore there is no BIOS screen on a Mac, as they don't have a BIOS.

    Also, the Core Duo processor in the MacBook Pro does not use Hyperthreading, since HT is a method for a single core CPU to emulate a dual core one. You need to find a Windows app that will permit you to turn off the second processor core like you can in OSX.
  4. grabberslasher macrumors 6502

    Aug 2, 2002
    Edit your Boot.ini to include the option to disable HyperThreading. You don't need a BIOS.

    "/ONECPU" or "/numcpu=1" will accomplish this.
  5. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    I believe that should be "/numproc=1",

    Good tip!

  6. cdpilkington thread starter macrumors member

    Apr 12, 2006
    Excellent, fixing the boot.ini file worked a treat. Thanks again! :)
  7. neilyes macrumors newbie

    Jan 17, 2010
    pls hel!

    hello! how disable the memory options on the bios set up of macbook in order for me to install a dual boot with windows. it says that i need to disable memory options ie: caching and or shadowing. :(

Share This Page