BiteSMS and LockInfo question

Discussion in 'Jailbreaks and iOS Hacks' started by pbkiller, Aug 25, 2010.

  1. pbkiller macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #1
    Hello there,

    I currently have LockInfo setup for when a txt message arrives, it blocks the Apple annoying popup alert, and instead it gives me the SMS notification on the lockscreen. I also have that when I tap the notification, it automatically opens up the default SMS app and i can type and reply right there (the threaded conversation between me and with the person im texting).

    I downloaded BiteSMS trial and now when I receive a txt message, the LockInfo notification comes up (as it did before), but now when i tap it, instead of taking me to the BiteSMS thread with the person im texting, it goes to the "Apple Styled annoying notification popup" from BiteSMS. When I slide to unlock, then it takes me to the BiteSMS threaded conversation.

    I have setup the Tap To Reply feature on LockInfo so that it opens BiteSMS. Does somebody know how to fix this? It's just an extra step, but its annoying as hell. Thanks for the help...

    Rob
     
  2. Vinnie Madrox macrumors 6502

    Vinnie Madrox

    Joined:
    Dec 23, 2009
    Location:
    HowELL, NJ
    #2
    Open up bitesms, on the top right tap the settings button, scroll down to Features then tap on lock screen. You can have the txt pop up like apple intended, or have a quick reply box pop up to reply right away, or set it to "do nothing", which sounds like what you are looking for.
     
  3. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #3
    Also go into Setting>Lockinfo>Plugins>SMS>Tap to Reply and change to biteSMS.

    EDIT: never mind that's not what you want..
     
  4. pbkiller thread starter macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #4
    Nope, didnt work. It still shows the "Apple Annoying Popup Alert" after tuning it to "Do Nothing". Before doing that, when i received a text message (while the phone was locked and screen turned off), the phone would wake up and the screen would turn on letting me know that there was a new text message. When i turned on the "Do Nothing" setting in BiteSMS, the phone would not wake up when receiveing a text message, I would have to manually wake it to see the new text.
     
  5. KoukiFC3S macrumors 6502a

    Joined:
    Jul 4, 2010
    #5
    Thanks! I was annoyed thatvehen I tapped on the SMS nothing happened.
     
  6. pbkiller thread starter macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #6
    I also have the Tap To Reply setting enabled and it still shows the "Annoying Notification Popup".

    The popup that im getting is not the one that Apple puts out, the annoying popup is part of BiteSMS...
     
  7. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #7
    quickreply use to bring up a transparent threaded style overlay with keyboard. It was the same as the native messaging app except it was transparent and would overlay on the lockscreen when you tapped to reply on lockinfo. Not sure if this is still working on 4.0.
     
  8. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #8
    If I undertands correctly you want to disable the Notification popup and just let LockInfo handel the notification, you need to do that on BiteSMS.

    go to BiteSMS setting, go to LockScree > Check "Show Nothing"

    If you want to get rid of those on the home screen you need to do the same on "unlock Screen Mode"
     
  9. pbkiller thread starter macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #9
    Basically...

    But if I go to BiteSMS and on the LockScreen i set it to "Do Nothing", when the phone is locked and I receive a text message, the phone will sound, but it wont wake up. I would have to manually press the home or sleep button to wake it, and then see the text message notification.
     
  10. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #10
    I don't think what you want is possible them, in order to wake up the screen you need to access the Notification system, LockInfo just reads it, don't send notification to it. If you disable BiteSMS notification, them there is nothing to bring the screen alive.
     
  11. pbkiller thread starter macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #11
    Ok, so basically here's what happens:

    photo 1 fixed.PNG

    I receive a Text message, LockInfo handles the notification perfectly... When i tap on it, it takes me directly to the message conversation (threaded view), where i can reply from there:

    photo 2 fixed.PNG


    But now when i receive a text message, although LockInfo handles the notification, when i tap on it:

    photo 1 fixed.PNG

    then this shows up:

    photo 3.PNG

    When i Slide To View, it takes me to the BiteSMS threaded conversation screen:

    photo 4 fixed.PNG

    Thats what i want to avoid.
     
  12. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #12
    OK first problem is easy too fix. Setting>Lockinfo>Plugins>SMS>Tap to Reply and change to iphone messages. What will launch the native over bitesms.

    EDIT: Second problem. Go into bite settings lock screen mode and change to Show apple alert. Lockinfo will handle notifications and the screen will light up on new messages.

    You might also consider quickreply, if they ever make it free like it's suppose to be, so you don't even leave the lockscreen to do what you want it too.
     
  13. pwb2103 macrumors member

    Joined:
    Jul 7, 2008
    #13
    Sorry to hijack, but I am having a similar (but not exactly the same) issue with bitesms and lock info. When I get a text I want to just double tap it in lockinfo and then have the keyboard pop up right away for me to start writing back. Instead, I double tap and get this stupid bitesms popup giving me the option to call, view, or close. I want to avoid the extra tap and just go straight to typing. is that possible with bitesms? Should I be using a different app instead? I've been searching and am struggling to get an answer.
     
  14. pbkiller thread starter macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Puerto Rico
    #14
    Most likely, removing BiteSMS and using the stock SMS app with QuickReply worked for me (but then again you lose some of the advantages of BiteSMS)... Im with a new i4 @ 4.0.2 so i cant test anything until the new JB is out... :mad:
     

Share This Page