BiteSMS causes "it safe mode"

Discussion in 'Jailbreaks and iOS Hacks' started by Loves2spoon, May 6, 2011.

  1. Loves2spoon macrumors 65816

    Loves2spoon

    Joined:
    Jun 3, 2010
    Location:
    California
    #1
    One of the iPhone's in my house goes into "it safe mode" every time bitesms is installed. Any way to fix this and keep the app without restoring the phone and starting over?
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    Install iFile from Cydia, then delete (right swipe) the following files and directories:

    /var/mobile/Library/biteSMS

    /var/mobile/Library/Preferences/com.bitesms.plist

    /var/mobile/Documents/biteadprefs.xml
     
  3. Loves2spoon thread starter macrumors 65816

    Loves2spoon

    Joined:
    Jun 3, 2010
    Location:
    California
    #3
    That will delete the whole app right? Than I can reinstall or do you think it was a bad download?
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    did you dowload it from the "featured" section on cydia?

    those are the instructions direct from bitesms if the app crashes when trying to load it

    wont delete the app just the "permission" files that cause the crashing issue


    ps wheres your avatar from, i recognize that face
     
  5. Biff... macrumors 6502a

    Biff...

    Joined:
    Jun 16, 2010
    Location:
    Sherman Oaks, CA.
    #5

    I had the same problem. Followed the instructions from bitesms and it corrected everything.
     
  6. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #6
    I am having this issues, it doesn't happen to me often so I haven't had a chance to see debug it, but When I receive a call, after hanging up, BiteSMS quick-reply appears, showing the same message that is last appeared for (even if there had been a conversation since.)

    I found this thread, so a lot of people seen to be having this issue

    http://forums.bitesms.com/forums/1/topics/3774
     
  7. nburwell macrumors 68040

    nburwell

    Joined:
    May 6, 2008
    Location:
    PHL
    #7
    I encountered this situation on Wednesday. I did a hard reset on the phone, and that seemed to work. However, I'm going to install iFile and remove those directories.
     
  8. gravytrain84 macrumors 6502a

    gravytrain84

    Joined:
    Jun 24, 2010
    Location:
    LA
  9. dudeabiding macrumors 6502

    dudeabiding

    Joined:
    Aug 24, 2009
    #9
    The beta seems to work fine- at least on my i4
     
  10. ZmyDust macrumors regular

    ZmyDust

    Joined:
    Feb 20, 2011
    #10
    I've never ben able to run BiteSMS on my verizon IP4 on 4.2.6. Crashes into safe mode every single time I open the program. When it's installed the SB crashes frequently even when not opening bite. I just now tried the above instructions and still the same result.

    The full story is here http://forums.bitesms.com/forums/1/topics/3611

    I gave up and now use iRealSMS. It runs flawlessly for me.
     
  11. Sparky9292 macrumors 6502a

    Joined:
    Aug 1, 2004
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Link?
     
  12. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #12
    I can't believe no one ever answered this. That's Andy Samberg of Saturday Night Live from the "Jizz In My Pants" video. Between that one and "D*ck In A Box", my two favorite SNL Shorts of all time. :D:eek::D
     
  13. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #13
    hahahah thanks
     
  14. Justinb51 macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #14
    Add this repo http://cydia.bitesms.com/ and install the beta it fixed all the problems I was having, some of which was mentioned above.
     
  15. mikejd1 macrumors 6502

    Joined:
    Oct 16, 2007
    #15
    Jiss in my pants, an SNL short
     
  16. djarpit macrumors regular

    Joined:
    Jun 9, 2009
    #16
    happened to me. re installed the ios. and works like magic
     

Share This Page