Bizarre aTV2 behaviour

Discussion in 'Apple TV and Home Theater' started by Stubaan, Sep 14, 2013.

  1. Stubaan macrumors newbie

    Sep 10, 2008
    Gainesville, FL
    Hi macgicians

    I have an aTV2 that is behaving badly.

    At some point a month or two ago it stopped being able to connect to the internet. I had it connected via ethernet, and was experiencing other odd connectivity issues with my home network (Cox was the service provider). Ultimately it appeared to be an issue with the modem, but while I was able to reconnect to the network on my MacBook I was never able to get the aTV back online.

    During this time I tried a number of things, ranging from factory resets to manual network settings, and got nowhere.

    After these experiments I noticed that the aTV thought an ethernet cable was plugged in even when it now wasn't. Even a factory reset wouldn't clear the manual network settings I had input, and I could do nothing to get it to instead search for a wifi network (that I was using successfully via MacBook and iPhone).

    I let the matter rest because I was moving, and assumed it was related to the modem issues which were never fully resolved. I have now moved to CA and tried reconnecting my aTV (completely new modem and network) only to face the same issues.

    I have no ethernet option so wifi is my only means of connectivity. I again restored the aTV to factory settings, and again could get no wifi option. However, after simply restarting the device via the Settings menu it suddenly reappeared, and I was able to connect successfully and watch a Netflix show.


    Then I tried to set up home sharing. Which failed, repeatedly - my password was not being recognized. I discovered then that the wifi connection had dropped, and the aTV once more thought there was an ethernet cable connected. I have not seen the wifi network option since.

    Any thoughts?

    I feel that the manual and likely erroneous ethernet network settings I added experimentally a month ago, which have persisted through multiple factory resets, are an important piece of this puzzle.

    Wifi connection is clearly still possible, because it just happened, but under seemingly unreproducible conditions.

    Solvable mystery?
  2. FreakinEurekan macrumors 68040


    Sep 8, 2011
    Eureka Springs, Arkansas
    Rather than restoring to factory settings via the UI, have you restored the software to the Apple TV using a MicroUSB cable and iTunes? If not, give that a try:
  3. Stubaan thread starter macrumors newbie

    Sep 10, 2008
    Gainesville, FL
    microUSB was my only option

    That is in fact the only way I was able to factory restore.

    Since I could not connect to the web the only way to do so restore it was via microUSB and iTunes.
  4. Stubaan thread starter macrumors newbie

    Sep 10, 2008
    Gainesville, FL
    C'mon folks - nobody has any thoughts?

    I've tried inserting and removing an ethernet cable, and checking to see if there are any obstructions in the port. Nothing.
  5. JohnLT13 macrumors 6502a


    Dec 9, 2012
    Boston (aka Red Sox Nation)
    Exchange it at Apple if its still under warranty, If it isent maybe they can still help. Im at a loss with your problem.
    Good luck.

Share This Page