Bizarre iTunes/Leopard trouble...write protected/locked file issues

Discussion in 'macOS' started by skootrtmbg, Jan 24, 2008.

  1. skootrtmbg macrumors newbie

    Joined:
    Jan 24, 2008
    Location:
    Louisville, KY
    #1
    I have a very odd situation in my iTunes since installing leopard...

    If I import a file into iTunes that was ripped or created on a different machine, it will not let me edit any of the ID3 info. I first noticed this when I tried to import a WAV file and tried to edit the artist/album info (yes, I know that Wav files have no ID3 tags, but they can be categorized within iTunes).

    When clicking get info, it woud show all the fields that are normally editable, but there was no drop shadow, and you could not edit any of the info. I tried to convert it to an MP3 just to see if it was an issue of WAV files not having ID3 tags, but it was the same thing with the MP3 file...completely uneditable. I also tried it with a full album of tracks imported into iTunes, (all highlighted, then "get info") and it let me change the info in the fields, but after clicking "OK", nothing changed in the iTunes library window. Finally I figured maybe I had to convert the ID3 tags, so I gave this a shot, and it gives me this error:
    "could not convert ID3 tags for all of the selected songs. The songs may be write protected or of the wrong type"
    Huh?
    I've done a pretty exhaustive google search and apple.com support search, and I get the impression that other users have had this issue, but no one has offered any solutions, and I thought maybe some people over here might have a better idea of what's going on...

    I have tried to tinker with the file permissions of the individual files in the finder, and found that some were read only, but even after fixing that on the individual files and re-launching iTunes, the problem persisted...even on files I converted on my own machine! Any ideas?

    also- before anyone yells at me- this is not a limewire stolen song issue, the bulk of these tracks are songs I created, though it has happened with legal rips of CDs I own as well...
     
  2. skootrtmbg thread starter macrumors newbie

    Joined:
    Jan 24, 2008
    Location:
    Louisville, KY
    #2
    also- here are screen shots showing the subtle difference I'm talking about in terms of editable info vs. non editable:

    editable:
    [​IMG]


    non-editable:
    [​IMG]
     
  3. 2Shae macrumors 6502

    Joined:
    Sep 7, 2006
    #3
    I have the same problem now...the last couple of days my Leopard has being doing weird stuff.

    Also I can't drag the audio files to another folder, it says I don't have the user rights or something like that.


    EDIT:
    Have you used Disk Warrior 4 recently?
     
  4. Toxman macrumors newbie

    Joined:
    Feb 3, 2008
    #4
    I've got the same problem with one album as well. There doesn't seem to be anything unusual about it, other than the fact that i can't add album artwork to it
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    Probably permissions issue (lack of permission on the new files), typically happens if music files are copied to cd, and copied to HD.

    Get info on iTunes music folder
    Under "Ownership & Permissions", look at details, and hit:
    "Apply to enclosed items"
     
  6. 2Shae macrumors 6502

    Joined:
    Sep 7, 2006
    #6
    Thanks!!!
    It worked.
    Had a little trouble finding the "Apply to enclosed items", but you have to press the little Gear with the triangle to see it.

    THANKS AGAIN!!!
     

Share This Page