Bizarre O2 iphone screw up.

Discussion in 'iPhone' started by Olliebear, Sep 22, 2008.

  1. Olliebear macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    Hey all,

    Just thought I'd tell you about my iphone upgrade adventure this week and wondered if anyone else has had similar issues.

    I bought an iphone 3G from an O2 store in London on Wednesday. I upgraded from a non 3G O2 phone so I was given a new sim card. For various reasons I didn't have time to set it up so it's been sat in its box for 5 days. I finally got round to setting it up last night. I put my new sim in the iphone and connected to itunes. Almost immediately a message flashes up saying 'Activation cannot be completed as a network cannot be found' Since then nothing has changed. Everytime the iphone is turned on it tries to activate but nothing happens.

    I've called o2 this morning and to my surprise they have no record of my upgrade, the iphone itself or the sim card. I'm still on my old tariff and as far as they are concerned I only have my old phone. I have to call again later to see if they've sorted it out.

    Anyone else had a similar problem?
     
  2. spooky2k macrumors 6502a

    #2
    hey there.
    I came across this 'error message' when activating my girlfriends iPhone 3G.
    The message come sup when you have no signal on the phone. So, find an area where the O2 signal is strong, keep it plugged into iTunes, and activate it. Once it picks up o2 network, be patient with it and leave it in the signal area for a while. It'll sort itself out.
    My girlfriends house is in the middle of nowhere, so it was hard to find signal. Sounds like you're having the same exact problem.
    Dan x
     
  3. Olliebear thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #3
    No it's not that. I live near the centre of London. I've checked the coverage and it's fine. I know a guy who upgraded 2 weeks ago who lives in the same building. His iphone activated no problem.

    The issue is with O2. They've told me the reason it wont activate is that the sim card doesn't work as they have no record of it being supplied to me. Therefore it's not connected to any account or tariff. I have to call them later with the sim card number (I don't have it with me now) so it can be corrected.
     
  4. mrtrilby macrumors member

    Joined:
    Jul 23, 2008
    #4
    Do you still have your original O2 SIM card (or anyone elses)? You ought to be able to activate it with that.

    I had a similarish issue when I upgraded. They gave me a new SIM in the shop, but told me to carry on using my old one. The phone activated fine...

    But after a few days, I realised Visual Voicemail wasn't working. Calling Customer Services revealed they had no record of me upgrading to an iPhone, what service plan I'd signed up for etc. It took about 24 hours for them to switch things over such that Visual Voicemail started working.

    A while after that I made my first foray into an area that actually had 3G coverage from O2. After a lot of fiddling I realised that my phone wasn't going to connect to 3G at all. Turns out that I should have switched over to the new "3G" SIM card. O2 gave me another new SIM card and it was back up and running in a few hours.
     
  5. Aurial macrumors 6502

    Joined:
    Sep 13, 2008
    #5
    Your issue sounds not too dissimilar to issues A LOT of iPhone 3G users experienced when we got the new 3G on or around launch day.

    There was some screw-up involving both O2 and Carphone warehouse whereby customers who bought the phone from either were not registered as having it. They then fed us all a load of bull for several days telling us it was going to be sorted by the end of the day etc.

    When I called they had no record of me either so I had to give them all my details over the phone including the SIM card number so that they could set up my account. I was eventually connected about 6 days after purchase.

    Sounds like there's still a few ghosts in the machine but you should be much quicker as you seem to be part of a minotity this time. They had thousands to get through in July.
     
  6. Olliebear thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #6
    Yeah, you guys are right. I should be able to sort it out tonight.

    What really worries me is I was told in the shop that because I upgraded from a non 3G tariff (with only 1mb of data per month included) I should wait at least 24 hours before using any data services as it was possible I'd be billed on the old tariff. Considering it's now been 5 days since I got the phone and I'm still on the old tariff I'm kinda glad it didn't activate! :eek:

    I'll post again if/when it's resolved.
     
  7. lfc200 macrumors member

    Joined:
    Feb 24, 2007
    Location:
    Cork, Ireland
    #7
    well what ou could do is if o2 still say that they have no record of you upgrading etc. Get your old sim card activate the iphone and then go to a o2 shop or a carphone and say that your sim card is damaged and ask them to do a sim exchange. They will automatically give you a 3g sim card. For the data side of things just get a data add on, then you will preserve your o2 upgrade as well so it will work out better for you in the long run
     

Share This Page