Bizarre power issue :-S

Discussion in 'MacBook' started by kingpeter, Dec 2, 2009.

  1. kingpeter macrumors newbie

    Joined:
    Dec 2, 2009
    #1
    Hi guys,

    I have a really strange issue with my Macbook (white 13-inch model). Around a week ago I got the sound notification that it was on reserve power so naturally I went to plug the magsafe power adapter in. Upon plugging it in I noticed that the LED on connector didn't light up at all and there was no change in the charging status on the Macbook.

    My girlfriend has the same model so I grabbed her power supply only to find that that didn't work either. I figured it may have been an issue with the batter (although the connector should light up with or without a battery in there) so I swapped the batteries around but to no avail. I then tried my battery and my power supply on her Macbook and everything worked perfectly.

    I made a reservation to take it into the Apple store. I explained the issue to the gent who was helping me so he plugged his power supply in and sure enough the connector lit up and everything was fine (sod's law!). He then connected my supply and to my amazement it was now working. I asked whether there was any difference in the power supplies but he said there wasn't. He carried out the hardware diagnostics test but all came back clear and indicated that there were no issues.

    Exactly a week later and the issue has re-occurred. Again I performed the same troubleshooting steps but nothing helped so I made another reservation to take it in. I was explaining the issue to another Mac user at work and showed him that there was no charge when my power supply was plugged in. He then suggested we try his to which I replied sure thing but it aint going to work! He plugs his in and what do you know it works and yet again I then plug mine back in and it works again. It turns out his power supply was an 85w power supply whereas mine is a 60w.

    I took it back into the Apple store and explained the situation to another guy and he told me that the power supply units they use are all 85w which would explain why it suddenly started up when I took it in the first time. He couldn't however offer any advice as he'd never seen such an issue before. He ran their hardware diagnostics test and once again no issues were detected.

    It's almost like plugging the 85w supply in 'jump started' the unit but it just doesn't make any sense. Has anyone come across this before?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Never heard of that before, very strange indeed.
     
  3. KielderWolf macrumors regular

    KielderWolf

    Joined:
    Aug 1, 2009
    Location:
    Northeast England
    #3
    Had the same problem. No current from the cable, and my laptop sat useless for two days. Borrowed a mates MacBook Pro charger, plugged it in, it worked. Afterwards, mine worked too. For a week. Then it stopped again. Did the MBP charger and again it worked. For two days. You can guess how frustrated I was.

    I bought a new charger from Apple and this one appears to be working. It also seems to have been built a lot better than the one that originally accompanied the MacBook last June. Upon prying the old one apart, the transformer block was incredibly warped.

    The new charger doesn't get anywhere near as hot as the old charger, neither.
     
  4. kingpeter thread starter macrumors newbie

    Joined:
    Dec 2, 2009
    #4
    Thanks for the response! To be honest I have considered just buying an 85w adapter to get around the whole thing. The only thing I can't work out regarding the charger is why neither of Macbook 65w power adapters I tried work on Macbook but they do on my girlfriends...it's an odd one thats for sure!
     
  5. Czicks macrumors member

    Joined:
    Jan 28, 2009
    #5
    Have you tried cleaning the connectors inside the power plug for both the Mac and the power supply?

    I've had to take a Q-Tip and rub the contacts clean once so the charger would function normally.
     

Share This Page