Bizarre Problem with AppleSpell.service

Discussion in 'macOS' started by appleweek, Feb 2, 2006.

  1. appleweek macrumors member

    May 20, 2002
    I am having a problem wish my OS X install. After extensive tests, I found out the problem is with the background system spellcheck service: AppleSpell.service. What happens is when I try to use apps that take advantage of AppleSpell.service (iChat, TextEdit,, other Cocoa apps), this message pops up in Console:

    2006-02-03 02:45:41.846 TextEdit[334] *** NSRunLoop ignoring exception '*** -[NSCFArray addObject:]: attempt to insert nil' that raised during posting of delayed perform with target 35d860 and selector '_preflightSpellChecker:'
    Then each time I try to type and enter a word (some letters followed by a space), I get the following in Console:
    2006-02-03 02:46:01.667 TextEdit[334] *** -[NSCFArray addObject:]: attempt to insert nil
    It seems as you enter a space char, AppleSpell tries to do its thing but fails. My system works fine otherwise, apps only give problems when using a Cocoa text entry field. For example, works normal to get and view e-mail, however once I open a Compose New mail window, AppleSpell tries to activate resulting in odd behavior in Similar situation in 2 other AppleSpell-aware apps I use, iChat and TextEdit. In the iChat conversation window, after every word, iChat reports an internal error and must quit. In TextEdit, the Control-click is not working when I click on words (as it would normally pull up the spelling service). I'm not sure how long the problem has been present, since I wouldn't regularlly use AppleSpell.service much.

    The strangest thing is, this bizarre problem only affects my own user account. I test the Spell service in a newly created user account and the root account, both of which worked fine and I saw the curvy red underlind below misspelled words. When I return to my account, I get the errors above. I've tried deleting countless prefs and .plist files of anything that appeared remotely related to spelling or dictionary in ~/Lib/Prefs. Also tried replacing my AppleSpell.service bundle located in /System/Library/Services with a new copy from another 10.4.4 Mac and it still wouldn't work in my account. Also ran Repair Disk & Repair Disk Permissions multiple times to no avail. What else can I try to get AppleSpell.service to be functional in my user acount????

    Running OS X 10.4.4 8G32 on 500MHz PPC G3 Mac.

    Pic of Console showing AppleSpell.service errors from TextEdit:
  2. appleweek thread starter macrumors member

    May 20, 2002
    Desperate for ideas.....

    What else can I try?

    What other .plist should i delete??
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I haven't seen this before and you've tried everything I can think of. Maybe it'd be easier to just migrate your settings to the new account. :eek:
  4. appleweek thread starter macrumors member

    May 20, 2002
    STILL pulling out my hair trying to get this issue resolved. I can't seem to let it rest....
    Anyway, I tried deleting/renaming even more and more PLIST prefs and it continued not to work. Then I decided to just rename the whole ~/Lib/Preferences directory. Didn't work. I renamed some more stuff in ~/Library. Didn't work. Renamed ~/Library itself. DIDN'T WORK. I've now tried just about every trick in the handbook that i've accumlated over years of being a Mac user to absolutely no avail. The more and more I try, the harder it is to give up and admit I encountered a problem in OS X i coudn't actually fix. Yes, its becomming an ego thing now (if you know what i mean).

    So far i've learned that the problem doesn't seem based in my home directory at all as I completely removed ~/Library (which holds all possible user-specific settings & prefsf) and it was regenerated on login, but the AppleSpell service probem persist! Why is my system targetting my user account ALONE?!

    Any possibles ideas I can try next??

Share This Page