Bizarre Problem with multiple phantom drives

Discussion in 'Mac mini' started by macinthebac, Aug 2, 2011.

  1. macinthebac macrumors newbie

    Joined:
    Aug 2, 2011
    #1
    I have a Mini Server (2x500, Snow Leopard) and it the system drive recently had a bit of a meltdown. I thought I could fix it by erasing the drive, reinstalling OSX Server and restoring from a backup.

    I can't do that though, because disk utility (both in the OS and off the install disk) will not allow that drive to unmount for any erasing/installing to happen. What's really wierd is in both Disk Utility and Disk Warrior a slew of "phantom drives appear" when the mini is target booted. They refuse to be ejected/unmounted. Pic below.

    Does anyone have any idea how I can unmount this drive to wipe/reinstall it? I've tried disk utility & disk warrior but neither can handle the system drive. I also tried the manual zeroing out command in terminal (sudo dd if="/dev/zero" of="/dev/rdisk1" bs=8m) but after a while it began returning reports of inactivity with timestamps.

    Any help is greatly appreciated!
    [​IMG]
     
  2. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #2
    have you tried the diskutil command in terminal?
    diskutil list
    diskutil unmountDisk
    diskutil eject

    it could be the disk utility app misreading the disk.

    there is also an emergency tool pack that you can burn onto a usb flash drive and boot from which has tools like tech tool pro and drive genius. google snow leo pro 911 1.5.
     

Share This Page