bizzare leopard disk image to FW drive problem

Discussion in 'macOS' started by shecky, Nov 6, 2007.

  1. shecky Guest

    shecky

    Joined:
    May 24, 2003
    Location:
    Obviously you're not a golfer.
    #1
    i have a 100% legal copy of the 10.5 install dvd disk image (we get it from school for free this way instead of paying for media) and i am trying to get it onto a firewire drive and im having some issues

    my understanding is i need a 10GB GUID partition (intel mac) on my external FW400 drive to restore the image to. i have the .dmg file on another external drive. in disk utility i then go to the 'restore' tab, select the .dmg file as the source, the empty 10GB partition as the destination, and hit restore.

    what happens is about 5 seconds later i get the following error:

    "an error (16) occured while copying (resource busy)"

    i have tried this 10 ways and i do not understand what the heck is wrong. i have mounted the DMG and it appears fine, but i need it on the external FW drive as a bootable partition.

    any ideas?
     
  2. Smoke macrumors newbie

    Joined:
    Nov 6, 2007
    #2
    Just boot to the install disk (Press C at boot up till you see the spinning wheel) and select your FW drive as the Destination.
     
  3. admiraldennis macrumors regular

    Joined:
    Aug 19, 2002
    Location:
    Boston, MA
  4. shecky thread starter Guest

    shecky

    Joined:
    May 24, 2003
    Location:
    Obviously you're not a golfer.
    #4
    that does not help either. what the heck am i missing here.

    im starting to get really irate with this. let me try and retrace my steps and maybe someone will see something i am doing wrong.

    i have available to me:
    -my Mac HD - 128GB, 16GB free
    -a backup external FW400 drive (called "backup") - 128GB, 2.5GB free
    -another external FW400 drive with 2 partitions: one is a 100GB empty partition (called "external"), the other is a 10GB GUID partition (called "mac os x install dvd")

    lastly, i have the image "Mac OS X Install DVD_10.5.dmg" that is 6.66GB and lives on the drive "backup"

    so what i just tried to do is the following:

    1. restart the computer
    2. mount all 3 FW400 drive paritions
    3. start disk utility
    4. click on the partition "mac os x install dvd" once
    5. select "restore" tab on the top right
    6. select "image" under source and navigate to the image "Mac OS X Install DVD_10.5.dmg" which is on the external FW400 drive called "backup"
    7. drag the partition "mac os x install dvd" from the left side of the disk utility window to the destination
    8. make sure "erase destination" is checked
    9. hit "restore"
    10 get this error message:
    "an error (16) occurred while copying. (resource busy)

    now what i am noticing is when this error occurs, the partition sometimes seems to unmount somehow, but not every time.

    i have tried repartitioning the drive a few times. previous to this it has worked flawlessly. i have tried mounting the .dmg file and it appears on the desktop normally; however, if i try to mount the .dmg file after i have unsuccessfully tried to do the restore, the finder pops up the external partition "mac os x install dvd" window to the front and nothing else happens - the disk does not mount. but if i then do a force-restart to the finder, suddenly the mounted image appears on the desktop and looks to work normally.

    so basically i have no idea what the hell is going on. any ideas?
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    I wonder whether the system is resetting the FireWire bus somewhere down the line and dropping the "connection" to the DMG. Try putting the DMG on your internal drive and restore from there.
     
  6. shecky thread starter Guest

    shecky

    Joined:
    May 24, 2003
    Location:
    Obviously you're not a golfer.
    #6
    just tried that.... and now get this........ i get an error that says "restore failure. an error (2) occurred while copying. (no such file or directory)"

    and at the same time that popped up, it appears as tho my partition "mac os x install dvd" unmounted - its now grayed out in disk utility.

    i assure you before tonight, these drives all worked flawlessly. the leopard image itself is 100% legal and not something i torrented. i have just restarted, repartitioned the FW drive, and plugged the drive directly into me MBP instead of daisychained thru another drive; i just got the identical error.

    wtf???
     
  7. shecky thread starter Guest

    shecky

    Joined:
    May 24, 2003
    Location:
    Obviously you're not a golfer.
    #7
    ok an update...

    i was noting all sorts of really weird stuff where the name on my FW partition would change to the name of the image and just other weirdness. so i did an erase of the entire FW400 drive first, and then did the partitions and as of the moment it appears to be copying properly with no errors.

    soooooooooo i guess that goes to show you erase your disk first THEN format? heck if i know.
     
  8. Smoke macrumors newbie

    Joined:
    Nov 6, 2007
    #8
    Put your install DVD in your computer.
    Hold Down Your "C" Key after you hear the apple chime.
    When you see the apple logo WITH the spinning wheel, let go of "C".

    This will start the OS X Installer.

    Select your lang.
    Click Continue.
    Click Agree.
    Select Your Firewire Drive and Partition.
    Click Options.
    Select Erase and Install.
    and just continue on with it from there.
    This will install OS X on that drive and you will be able to boot to it by Holding down your option key after the apple tone and selecting your Firewire drive.
     
  9. shecky thread starter Guest

    shecky

    Joined:
    May 24, 2003
    Location:
    Obviously you're not a golfer.
    #9
    reread my original post. i do not have an install DVD, i have an install disk image that i am trying to put onto an external drive as a bootable volume to then install leopard onto my hard drive.

    which, by the way i have now successfully done (onto the empty partition on my external just to see how it works before i do it on my main drive while i wait for 10.5.1)
     

Share This Page