Black and white screen on machintosh classic II

Discussion in 'Apple Collectors' started by Neaneajustinish, Mar 31, 2018.

Tags:
  1. Neaneajustinish macrumors newbie

    Neaneajustinish

    Joined:
    Mar 31, 2018
    #1
    hi , i just bought a machintosh classic II for a really low price and it is very new . However when i switched it on i found that it only shows a screen with black and white stripes. I used contact cleaner to clean the motherboard and it still doesn’t work . Any solutions ? Thank you !
     

    Attached Files:

  2. AngerDanger, Mar 31, 2018
    Last edited by a moderator: Mar 31, 2018

    AngerDanger macrumors 68040

    AngerDanger

    Joined:
    Dec 9, 2008
    #2
    One of my favorite YouTubers had the same thing happen.

     
  3. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #3
    That is 100% symptomatic of bad capacitors on the logic board-a problem for which the Classic and Classic II are notorious.

    Sometimes washing the board will bring it back to life for a little while. Otherwise, recapping really is the only permanent fix. The boards are big enough that it's not insurmountable, or there are a handful of different folks who will do it for you.

    Honestly, though-I hate to say it but I had a Classic with bad caps and ended up just looking for one with a bad case that worked and swapping the boards as Classics aren't worth enough to pay someone to recap. I'm lucking in that my CII works on its original caps.

    If I hadn't found a replacement LoBo for my Macintosh II, it absolutely would have been financially viable to recap and some others(IIfx, Quadra 840AV) are no brainers.

    One last thing-if the battery has leaked, you can probably write off the board completely and just need to hunt for another.
     
  4. MikeatOSX macrumors regular

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #4
  5. Atomic77 macrumors regular

    Atomic77

    Joined:
    Jul 8, 2017
    Location:
    West Bend Wisconsin
    #5
    I had one of these as my first computer a long time ago. It worked great but one day it completely died and could not be saved.
     

Share This Page