Resolved Black bars on 4K LG display with 2016 13" MBP, not using full display area

Discussion in 'MacBook Pro' started by jun180, Jun 2, 2017.

  1. jun180 macrumors regular

    jun180

    Joined:
    Apr 27, 2010
    #1
    Hi all,

    I just bought an LG 27UD88 27" monitor, as recommended in the Macrumor 4K Display buyers guide (here). This display has USB-C and is similar to the LG Ultrafine models in terms of specs and connectivity.

    I am having issues with the display on a 2016" 13" MacBook Pro (non-touch bar). When connected via USB-C or HDMI, the MBP does not utilise the full display and there is a black border about 1 centimetre thick between the bezel and the OS desktop. The laptop is not using the full display, and the image looks under scanned. Refer to the attached screenshots.

    I have tested with a 2014 MacBook Air via MiniDisplayport and there are no issues, and the screen is fully utilised. I have also tested with my work Windows laptop and have no issues.

    Can anyone recommend a course of action to fix the issue? I have tried swapping cables and ports, NVRM and SMC reset, tried using SwitchResX software, adjusted all the display settings in OSX, and played with the settings of the monitor but I suspect its an issue with the MPB not displaying properly.

    Any help would be appreciated.

    Thanks,
    Jay
     

    Attached Files:

  2. jun180 thread starter macrumors regular

    jun180

    Joined:
    Apr 27, 2010
    #2
    Issues now resolved. Booting into safe mode has fixed the issue, it must have reset the display settings in OSX. Leaving this note for anyone experiencing issues with their 4K display.
     
  3. Merkava_4 macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #3
    How do you boot into safe mode if you don't mind me asking?
     
  4. jun180 thread starter macrumors regular

    jun180

    Joined:
    Apr 27, 2010
    #4
    Shut down the computer, turn the power on and hold the shift key until the apple logo appears. Then you'll end up at the login screen and you should see the words safe mode in red in the menu bar.
     
  5. Merkava_4 macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #5
    Thank you sir. I figured I should ask now before this thread gets buried in the archives.
     

Share This Page