Black iPhone 4 Midframe. (Soon with Pics)!

Discussion in 'iPhone Accessories' started by readerbreader, Apr 5, 2011.

  1. readerbreader macrumors regular

    Jun 7, 2010
    So i took the plunge and ordered the black midboard frame for the iphone 4. Should be here in the next few days, (maybe a week) i will have pictures up of the completed conversion.
  2. guccigucci88 macrumors 6502a


    Dec 30, 2010
  3. gcarlucci macrumors member

    Jan 18, 2011
    Herndon, VA
    and whats that?
  4. readerbreader thread starter macrumors regular

    Jun 7, 2010
  5. ajsnow6234 macrumors 6502

    Apr 9, 2010
    Pointless thread...just post a thread WITH pictures when it's done...
  6. weisjt macrumors 6502a


    Dec 8, 2010
    Southern Pines, North Carolina
    i think it will look cool cant wait to see the pics
  7. Austin M. macrumors 6502a

    Austin M.

    Jul 29, 2010
    Same here, I think that the gold looks cool as well.
  8. calvy macrumors 65816

    Sep 17, 2007
    I'm wanting to do similar mods but I don't think I have the patience to wait up for shipping from sw-box
  9. vincenz macrumors 601


    Oct 20, 2008
    Why would you get rid of all that nice brushed stainless steel?
  10. holladiewaldfee macrumors newbie

    Jul 6, 2011
    no gms- signal

    I also bought a black mid plate for my iPhone 4 and it arrived today. Excited i installed all parts in it, everything went smooth until the phone was powered on: no signal... wifi was working, gms/edge and gps not. I tried to scratch off the "paint" on the contact-spots but this didnt helped at all. I also put the loudspeaker/gms- atenna-part in my original mid-plate and connected the antenna with the logic board installed in the black mid-plate and voilà it obviously there is a problem with my mid plate.
    I bought it from, never had a problem with parts from them.

    any help would be really appreciated!

    @readerbreader: nice phone!
  11. Wafflausages macrumors 6502

    Jun 27, 2010
    could be one of the screws i remember reading on modmyi or ifixit someone had a similar problem and it was just one screw not tightened enough could be wrong but it would be worth double checking :)
  12. holladiewaldfee macrumors newbie

    Jul 6, 2011
    thanks for this quick answer..thought i double- checked every little piece but...well, never be too sure. i'll retry the whole thing. i already took off the "paint" with my dremel.
    are there any other contact- points for the gsm- antenna beside to top of the logic-board that i am not aware of?
  13. readerbreader thread starter macrumors regular

    Jun 7, 2010
  14. jdaniel macrumors 65816

    Mar 21, 2009
    Ottawa, Canada
    completed pics?
  15. holladiewaldfee macrumors newbie

    Jul 6, 2011
    turned out there is probably something wrong with the part since another customer of reported them having similar issues with their black mid-frame (tech-support from cnn told me, also that they hadn't signal issues before)
    i will get a new one or a refund from them.
    thanks again for the replies!
  16. readerbreader thread starter macrumors regular

    Jun 7, 2010

Share This Page