black isight image (it's not a stupid question, really)

Discussion in 'Mac Accessories' started by tirethminet, Jul 27, 2008.

  1. tirethminet macrumors newbie

    Joined:
    Apr 28, 2008
    #1
    this is a good one, promise.

    i have a intel-based macbook, just bought maybe january-ish?
    the built-in isight has decided to give me no picture.
    also, i haven't used the isight in about a month or so, but it was working fine then.

    in ichat, the green light comes on and the mic is working, but there is just black where the image should be.
    and in photobooth, again, a black image.

    so it's not the program, i checked system profiler and the isight registers, and it's not user-specific because i'm the only user on the mac and i haven't changed any preferences since the last time i used the isight.

    haven't reset the smc, but i really would like to use that as a last resort. (only if it has worked for anyone who has had the same problem or no one has a different solution)

    so any answers or speculations? :]
     
  2. tirethminet thread starter macrumors newbie

    Joined:
    Apr 28, 2008
    #2
    even if you just post to say "that's sad, can't help you" i really would love to know if anyone is reading this
     
  3. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #3
    it's hard to read with such a low contrast and small font.
     
  4. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #4
    i honestly have no idea what the issue could be. i'll look into it though.
     
  5. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #5
    okay. i found some stuff on the problem.

    check this article on apples site, it may help: http://support.apple.com/kb/HT2090?viewlocale=en_US

    Some users on Apple's discussion forums claim they have found a fix to the issue: make sure your macbook isn't plugged into the power source, then hold your power button in for 10 to 15 seconds until it turns off, and then plug it back in and give your photobooth a go.

    Some users say this works: Try doing a Parameter RAM reset - hold down apple/option/p/r keys at start up and wait for three chimes before releasing the keys.
     
  6. tirethminet thread starter macrumors newbie

    Joined:
    Apr 28, 2008
    #6
    tuffluffjimmy:
    i actually have it as that specific green so that people can read it on most color backgrounds.
    and it's only one size smaller than the standard font size.

    macbookairman:
    thank you so much. i had checked the troubleshooting article on apple, but it helped with nothing.
    the unplugging and then restarting fixed it, though. (although just restarting did not, odd.)
     
  7. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #7
    hey, you know what color 100% of backgrounds on Macrumors are? White. You know what has a high contrast to white? Black. You know why the default font is what it is? Because it's easy to read.

    thanks

    PS: your wiring between your logicboard (I think that's where it connects) and your iSight has come apart. Take it into an Apple Store.
     
  8. muldul macrumors 6502

    Joined:
    Apr 21, 2008
    Location:
    West Sussex, England, UK
    #8
    Try changing your font and colour please, and i had this problem once, but when i restarted photo booth it went away
     
  9. tirethminet thread starter macrumors newbie

    Joined:
    Apr 28, 2008
    #9
    tuffluffjimmy:
    i use it as my font everywhere so i can find my posts easily, and not every forum is white.
    please don't be rude.
    and the problem has already been solved.

    muldul:
    restarting photobooth did not make it go away because it was not a problem with the apps, but with the isight.
    and i will keep my font as it is, thank you.
     

Share This Page