Black screen after Apple logo boot from OS X Leopard DVD

Discussion in 'MacBook' started by thehumble1, Dec 3, 2010.

  1. thehumble1 macrumors member

    thehumble1

    Joined:
    Apr 9, 2008
    Location:
    West Philly
    #1
    Here's the setup:

    Macbook: A1181 Core 2 Duo 2.0ghz 1GB RAM

    DVD disk: Leopard 10.5 Retail install

    Hard drive: dead (spins with clicks).


    With regular startup I get the flashing question mark and can hear the failed hard drive click and spin. After getting the DVD to boot in the drive (it doesn't suck it in right away), I get an apple logo and pinwheel like I should, but after about 30 seconds it goes to a black (blank) screen and the DVD spins down, but not all the way. The computer is still on, but nothing happens.

    Oddities:

    <>If I start it with an iMac 10.4 DVD I can boot to the install screen just fine, but can't install because it's an iMac DVD. I can erase and partition the drive fine (not the dead one, another one I have).

    <>Safe mode boot does the same thing, but takes 20 times as long to boot

    <>Retail OSX 10.4 DVD does not boot at all, but that one might be for PowerPC computers. I get the flashing question mark folder.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    Having a bad hard drive connected can make bad things happen. Remove the bad hard drive. Otherwise, your 10.5 disc is probably bad.

    The very first Intel machines came with 10.4, so there was never a retail release of 10.4 that would run on Intel Macs.

    What are you trying to do? It sounds like you have a bad hard drive inside the machine, but you're trying to install 10.5 on an external hard drive. Why would you do this??

    Anyway, other things you can try: Boot your iMac from the disc. It came with 10.4, so it should be able to boot from the disc, assuming the disc is good. Install on your external hard drive. Update to 10.5.8 with the combo update downloaded from the Apple site. This will install all drivers for all Macs, not just the one running Software Update. Then this drive should be able to boot your MacBook.
     
  3. thehumble1 thread starter macrumors member

    thehumble1

    Joined:
    Apr 9, 2008
    Location:
    West Philly
    #3
    thanks for the feedback.

    Here's what I know now.

    It isn't the hard drive because I've put 2 other drives in it, one brand new.

    It isn't the software because I've tried a lot of disks. The iMac disk I tried wasn't a retail, it is the original software reinstall disk. it's weird that this worked when the others didn't. It is for a Core 2 Duo iMac.

    I started the Macbook in safe mode and finally got what I think is the error it is:

    Kernel Panic: Unable to find driver for this platform "ACPI". I think that means the SMC isn't working properly, which is why the battery isn't charging and the Macbook boots when plugged in.

    I think that also means the notebook is toast, because there's no way to update the power control firmware outside of OS X and I can't boot to OS X. Is there any way I can upgrade or reinstall the firmware from a bootable disk? I think there might be a chance because I can get the 10.4.8 iMac disk to boot. I can also get a 10.4.6 Macbook disk to boot, but it won't install either.
     

Share This Page