Black screen after switching drives Late 2011 MBP

Discussion in 'Mac Basics and Help' started by tuna, Sep 8, 2014.

  1. tuna macrumors 6502

    Joined:
    Apr 11, 2010
    #1
    I have a 17" Late 2011 MBP. I had a clean updated install of Mavericks on the HDD and a Superdrive also in the computer. I successfully ran Boot Camp to install Windows 8.1 on the HDD. I was able to boot between the Windows and Mac partitions.

    I then opened up the machine, moved the HDD to the superdrive slot, and put in my SSD that has a Macintosh install that I had previously used with this computer. As in, before I put the HDD in the computer, I had this SSD in, and I haven't deleted anything from it. Theoretically I should be able to boot to that SSD.

    The problem is that now my computer starts but the screen is black. It seems to be completely working as in (1) I hear the start chime (2) the keyboard backlight turns on and is responsive to keyboard commands (3) the caps lock key lights on/off when pressed (4) When its on and I press the power button it makes the normal Mac OS honks at me (5) when I press other buttons it also honks at me as if I'm in a menu and doing the wrong thing. Its just the the screen went dark.

    I really don't think I broke anything while I was in the computer. Everything seems to be attached.

    I have reset PRAM and that didn't seem to do anything. I have tried to reset SMC although I don't know how I'd know if that was successful. I have also held down shift and the power button at the same time, which supposedly boots into safe mode, but I don't know if that is working. If it is it isn't helping my black screen situation.

    Any ideas?
     
  2. shanelee macrumors newbie

    Joined:
    Sep 4, 2014
    Location:
    Sydney
    #2
    Screen problem

    Hey,

    I think there is a screen connection problem may occur, the mostly the reason behind the screen get blank and after some time start working correctly.
     
  3. tuna thread starter macrumors 6502

    Joined:
    Apr 11, 2010
    #3
    I suppose its possible but from what I understand, the video cable is on the opposite side of the computer from where I was working on the superdrive. Its a relatively thick cable that wouldn't easily break and I double checked it and everything seems secure.

    I am inclined to believe that this has something to do with the BIOS not expecting the right drive causing this somehow. I also read someone with the same symptoms that said that the "sleep image" was the culprit and that using target disk mode and deleting or resetting the disk image fixed it.
     

Share This Page