Black screen after update to 10.12.2 iMac

Discussion in 'macOS Sierra (10.12)' started by skadd, Dec 13, 2016.

  1. skadd, Dec 13, 2016
    Last edited: Dec 13, 2016

    skadd macrumors regular

    Joined:
    Mar 5, 2010
    #1
    Edit: Solved.

    Completely black screen after booting up with 10.12.2. I can adjust the volume and brightness and move the mouse around.

    iMac 27" mid 2010

    Thanks Apple..

    IMG_2072.JPG
     
  2. HarmonicaNomad macrumors newbie

    HarmonicaNomad

    Joined:
    Nov 10, 2009
    Location:
    Thailand
    #2
    Same problem on MBP 15" 2.8 GHz Intel Core i7.
    I had to re-install 10.12.1.
     
  3. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #3
    How do I do that without losing any personal files?
     
  4. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #4
    how long you waited? I got blank screen for about 5 minutes and then it continued the installation.
     
  5. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #5
    Yes, here too. I left and started supper, came back, still black. Pressed the space bar, entered my password and viola. You guys need to be more patient.

    Lou
     
  6. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #6
    Maybe I wasn't clear. It finished the installation. Desktop was showing. I restarted for some reason and by the time the apple logo and loading bar was gone it was all black.

    If I wait a couple of days will I be able to reinstall with a newer fixed version through "internet recovery" ?
    --- Post Merged, Dec 13, 2016 ---
    How long are we talking?
    I don't need to type in a password when booting up, but I'll try.
     
  7. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #7
    Oh. Sucks!
    Well, try to boot into recovery mode and run a disk repair on the main drive. see if it helps.
    If you have the chance, download on another device the full installer and make a bootable USB and simply install over existing and this way you will not loose anything.

    It's all I can think about.
     
  8. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #8
    This is so strange. I waited several hours staring from time to time at the black screen. I decided to try entering my password and hitting enter even though I didn't see anything and voila. I'm back in!

    Thanks @flowrider
     
  9. sbpax macrumors member

    Joined:
    Apr 29, 2016
    #9
    This update is buggy as hell. Got black screen and 2 crashes in less than 30 minutes. MBP 13 touch bar.
     
  10. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
  11. Frankfurt macrumors regular

    Frankfurt

    Joined:
    Dec 4, 2016
    Location:
    USA
    #11
    10.12.2 corrupted my user profile with distorting desktop setup and slow on reboot etc. After SMS and Oran reset and profile cache delete, I finally gave up and called apple support. One hour later with no success I am restoring from time capsule to latest backup of 10.12.1
    2016 MacBook Pro 15/2.9/460/1T
     
  12. al404 macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #12
    mac mini and same issue, after trying different tricks i'm installing over from recovery, hope i will not lose anything
    if is not working how long would it take to recover from TM?
    do i enter recovery and select restore from TM from there?
     
  13. GooberMan, Dec 14, 2016
    Last edited: Dec 14, 2016

    GooberMan macrumors member

    Joined:
    Feb 20, 2014
    #13
    Same problem, Mac mini late 2014. Did not try the space bar, but could still get the dock to show up for a split second with a four finger swipe up on the track pad.

    Really really annoying. Spent an hour or so chatting with Apple Support, with no solution, and their claim of "this is not an emerging issue". Yet here we are.

    Currently going through another install, this time after an HD erase (I can easily recover files), though it sounds like it won't help any.

    I don't think I've ever gone through an Apple OS update, or iOS update for that matter, without major issues. Tim Cook needs a smack upside the head.
     
  14. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #14
    I've been a Mac user since 1986, yes that's 30+ years. In all that time, I've only had one OS update go awry. As I recall it was 4 or 5 years ago. Can't remember the update! It was on my MBA, not my cMP.

    Lou
     
  15. GooberMan macrumors member

    Joined:
    Feb 20, 2014
    #15
    I've been an Apple user for a few years now. I wish I had a better experience, I really do.

    The HD erase and install fixed this by the way. Maybe not an ideal solution for people running into this problem, but it was a solution for me, as I do have a Time Machine back up of files.

    The steps I took were:

    1. When powering on hold command and R to go into recovery.
    2. Choose Disk Util and erase the volume.
    3. Rename the disk and choose Mac OS Extended.
    4. Quit Disk Util and choose reinstall MacOS.
     
  16. EdwinZelf macrumors newbie

    EdwinZelf

    Joined:
    Dec 15, 2016
    #16
  17. Lankyman macrumors 68000

    Joined:
    May 14, 2011
    Location:
    U.K.
    #17
    Same with my iMac though I was getting concerned at one point. My iMac also made the loudest sound when going through the upgrade. It sounded like I had my finger pressed on a key with volume on full, a loud single note.

    All well again though when machine booted up.
     
  18. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #18
    The loud single note means it installed a firmware update.
     
  19. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #19
    I had previously the beta versions which installed that FW Update.
    I think it was during installation a point when everything went fully black.

    I wish I could enable somehow Verbose mode of Updates... so I see what's actually going on.
     
  20. Norman49 macrumors newbie

    Norman49

    Joined:
    Dec 15, 2016
    #20
    For me too, the installation finished with... a black screen. I restarted many time, with or without extensions... Black screen.

    This morning i started... with black screen... and let the computer on for i had another job.
    When i went back some hours later, i had to log and it worked just fine.

    Be happy, don't be hurry ;-)
     
  21. JesseSsmith79 macrumors newbie

    JesseSsmith79

    Joined:
    Dec 15, 2016
    #21
    Has anyone tried this yet. Ive been dealing with this for 2 days. Im able to go back to 10.12.1 using Time Machine but as soon as I upgrade to 10.12.2 I get a black screen with my curser.

    Ive tried reseting my PRAM & SMC. Nothing seems to work.

    Currently I'm at work and I can't wait to see if EdwinZelf post works.
     
  22. Amwar, Dec 15, 2016
    Last edited: Dec 15, 2016

    Amwar macrumors newbie

    Joined:
    Dec 15, 2016
    #22
    I just got off the phone with Apple support and they were just updated with the following instructions on how to fix this. Very similar to what is in the link provided by Edwin apart for the need to remove the .AppleUpgrade file.

    Restart in single user mode (Command-S when starting)

    mount -uw /
    cd /Library/Preferences
    mv com.apple.loginwindow.plist com.apple.loginwindow.plist.old
    reboot

    I haven't tried this yet as I don't have the time to restore from my Time Machine backup for the fourth time if this fails. I'll try tonight.

    Update: I just tried this and ran into SandboxViolation errors when trying to rename the file. I called Apple and they were of no help. I googled some more and found out I had to boot into Recover mode, go to a Terminal and disable the SIP (csrutil disable). I then booted back into single user mode and was able to rename the file. When I rebooted I can now log back in.
     
  23. ArtPiCard macrumors newbie

    Joined:
    Dec 15, 2016
    Location:
    Lima, Peru
    #23
    I had the same problem today. All day long trying and failing... I tried resetting NRAM, SMC, disk repair, safe boot and so on. Nothing worked.
    Finally, I entered Recovery Mode and restored to the previous version of Sierra from my Time Machine external drive (fortunately I had it updated and perfectly working). It took very long but my MBP seems to be running ok for now.
    I have a MacBook Pro 2013.
    Is this happening to anybody else? Is this a problem with that last Sierra update? Is my MBP too "old" for that update? Any comments? Any advice?
     
  24. Cardsnk macrumors regular

    Joined:
    Jul 18, 2013
    #24
    try to enter your password twice at login (assuming you are in desktop), even if the cursor is the only one showing.
     
  25. tuncer macrumors member

    Joined:
    Mar 19, 2008
    #25

Share This Page