black screen and half a chime =(

Discussion in 'iMac' started by notpaul, Feb 6, 2008.

  1. notpaul macrumors newbie

    Joined:
    Feb 6, 2008
    #1
    I have a mid-2007 imac that will not longer boot...

    Yesterday it rebooted itself and I couldn't figure out why... fast forward to this morning.. i woke up to the chime noise. the screen remains black and it seems to cycle the attempted boot process halfway through the chime noise (at this time you hear the HD start to spin up about half a chime and it reboots itself).. I've tried all of the option+% commands and holding down d,c,etc. with no luck. Holding down the power button for a while will make a loud beep.

    I'm wondering if this has to do with the aftermarket ram i installed over a week ago. i tried putting in the factory ram and resetting the ram to no avail.

    Could the firmware be corrupted? If so, can someone point me to the correct firmware to download for a mid-2007 24" imac?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    If it's mid-2007 iMac it's under warranty, contact AppleCare.
     
  3. notpaul thread starter macrumors newbie

    Joined:
    Feb 6, 2008
    #3
    it is, but i'd rather not pack it up and lug it around to get repaired. i wont be able to contact applecare until this evening so i was hoping for some things to try if that failed.
     
  4. FJ218700 macrumors 68000

    FJ218700

    Joined:
    Mar 8, 2007
    Location:
    Blue Dot, Red State
    #4
    are there 2 RAM slots? I've had a slot go bad before with symptoms you're describing?
     

Share This Page