Black Screen at Startup

Discussion in 'iOS Programming' started by joshsroka, Oct 17, 2008.

  1. joshsroka macrumors member

    Joined:
    Oct 2, 2008
    #1
    why when my app starts is there a black screen on for a little bit, then the app?
     
  2. joshsroka thread starter macrumors member

    Joined:
    Oct 2, 2008
    #2
    ok from google i found out it sounds like i need to assign a launch image, how do i do that if that is the answer?
     
  3. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #3
    You read the Apple provided documentation which will tell you the answer.
     
  4. Pring macrumors 6502

    Joined:
    Sep 17, 2003
    #4
    I'll throw you a bone... search for references to Default.png in the documentation.
     
  5. joshsroka thread starter macrumors member

    Joined:
    Oct 2, 2008
    #5
    thanks guys, i love this forum and the help it provides, and you are right i should read the documention, sometimes it is just easier to throw and a question and but i am going to read that documentation now, thanks
     
  6. Brendan.Porter macrumors member

    Joined:
    May 19, 2007
    Location:
    Between tourists, corn, and windmills.
    #6
    Default.png

    All you have to do is include in your Resources a properly iphone-sized graphic that you wish to use as a startup image. Drop it in the Resources folder and it magically works without any code.

    Make sure it is named "Default.png"
     

Share This Page