Black Viewer in iMovie '09 and '11

Discussion in 'Digital Video' started by dasikes, Jun 8, 2011.

  1. dasikes macrumors 6502a

    dasikes

    Joined:
    Jul 10, 2008
    Location:
    Alabama
    #1
    Hello! Sometime last year, this problem began with iMovie '09 on my old iMac, and has persisted into '11 on my new iMac.

    When I am in iMovie, I can see thumbnails just fine. When I scrub or play footage, however, no video appears in the viewer. I can hear audio, and what is especially weird is that iMovie still acknowledges that there is color there (things like the white balance eye-dropper detect color) and the histogram reflects color, but I can not see any.

    I have been searching all over for a solution and can't find it. I've dumped whatever caches I could find, reinstalled the software, repaired disk permissions, etc.

    This footage is fully compatible with iMovie - it's mostly shot on the iPhone 4.

    Any help? Thank you!
     
  2. DavidLancaster macrumors newbie

    Joined:
    Aug 28, 2011
    #2
    Black viewer in iMovie '11

    I'm having exactly the same trouble as dasikes. I just bought iMovie '11 because iMovie '08 crashed if I tried to do anything with titles or transitions. Now I can't use iMovie '11 at all because of the black viewer.

    Did anyone have any suggestions for dasikes?

    Thank you.

    David
     
  3. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #3
    Try deleting the iMovie .plist, which you'll find in Home Folder>Library>Preferences.
     
  4. DavidLancaster macrumors newbie

    Joined:
    Aug 28, 2011
    #4
    Dave thanks very much for replying. I had actually tried removing the .plist, as it seemed to be one of the more plausible solutions on the forums. Still no luck though and I also discovered that the previous bug that had prompted me to buy the new version of iMovie was also present in this version! (If I click on transitions, it still crashes!)

    I got cross and wrote to iTunes and a very helpful chap promptly replied and said they would refund me and that Apple would work on it.

    It seems so difficult to diagnose these things, but I really hope I can be using iMovie again soon. The only thing I can do now is use the app on my iPhone, but at least it only cost £2.99!

    Cheers

    David
     
  5. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #5
    Any updates on this? I tried damn near everything and nothing has worked.
     
  6. karlth macrumors regular

    Joined:
    Apr 13, 2010
    #6
    iMovie's photo handling is seriously buggy. I had the same problem what finally worked was:

    1. Deleting the cache in user folder/Library/Caches/iMovie
    2. Restarting a new project as NTSC 30fps.

    I have no idea why that worked but it did. Hope it works for you too.

    Anyway I just replaced a photo in my project and that meant that all the photographs shifted causing a different photo being displayed in the preview window and in the timeline.

    :mad:
     
  7. karlth, Dec 1, 2011
    Last edited: Dec 1, 2011

    karlth macrumors regular

    Joined:
    Apr 13, 2010
    #7
    This seems to having something to do with the actual files, either the filesize or some attributes. Try renaming the troublesome files and if possible compressing them more. It at least worked with one of the files.

    Update: Then it stopped working in the next project.

    I wouldn't recommend iMovie in current form as although it is a nicely designed product this bug seems to be a critical showstopper.

    I'll update this thread if I find a solution.

    Update #2: Suspecting that this was connected to iMovie's strange handling of JPEG files I tried converting the photos to TIFF before using them in a project.

    So far so good. (fingers crossed)
     
  8. karlth macrumors regular

    Joined:
    Apr 13, 2010
    #8
    So I've gone through a short project without any hiccups. The trick was converting all image files to compressed .TIFF format before dropping them into the project. iMovie is obviously unable to handle certain .jpeg files even with no plug-ins or codecs installed.

    Hope this helps.
     
  9. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #9
    Curiously, I don't think I've used any images in this particular project, just video.....
     
  10. karlth macrumors regular

    Joined:
    Apr 13, 2010
    #10
    Based on what I saw with the photo formats I'd recommend converting the videos to another format and reimporting them into a new project.
     
  11. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #11
    Oh I figured out the issue/solution.

    Apparently iMovie didn't like me having that many video files in one event. I just split the videos into multiple events and problem solved.
     

Share This Page