Black & White not working?

Discussion in 'Mac and PC Games' started by chaoticbear, Mar 24, 2008.

  1. chaoticbear macrumors 6502

    Joined:
    Jul 25, 2007
    #1
    I'm trying to play Black & White, but when I click on the icon, the screen flickers for a moment, then says "Black & White could not initialize the display on this machine. Please switch to an 800x600 resolution and try again."

    I've tried both the 800x600 regular and stretch options under System Preferences|Display, I've tried reinstalling and restarting the computer, but still nothing. I have an external display I could try running it on, but I don't have an adapter that's appropriate.


    I'm running it on a late 2007 Macbook, 2.2 Ghz, 4GB RAM.
     
  2. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #2
    Try setting Black & White to run in 32-bit colour. Apple's drivers for the GMA X3100 does not support lower colour bit-rates.
     
  3. chaoticbear thread starter macrumors 6502

    Joined:
    Jul 25, 2007
    #3
    How do I go about doing that? The only other options in the display options is a disabled 256 colors, context clicking on the B&W icon doesn't bring up an option to do it, and searching the forums and Google isn't helping either.
     
  4. chaoticbear thread starter macrumors 6502

    Joined:
    Jul 25, 2007
    #4
    I emailed the company, and this is their reply

    So I might be able to play it eventually. Oh well.

    Anyone want to trade their MBP for my MB? :p
     
  5. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #5
    Here's how I got Black & White to run under Leopard.

    First open this file using TextEdit:
    ~/Library/Preferences/Lionhead/Black & White/Preferences Data

    Find the line that reads:
    <value name="ScreenD" type="integer">16</value>

    Change 16 to 32.

    Save the file and launch Black & White. The game should run now.


    PS: Sorry for the much delayed reply. Been busy and didn't try running this game till now.
     
  6. PcBgone macrumors 6502

    PcBgone

    Joined:
    Feb 3, 2008
    #6
    WoW! Thanks for posting this! I never got to play this game when it first came out. I decided that it would be a good buy for my wife's new macbook, as I await my income tax return for my new iMac. I was sorely disappointed to find that the new macs couldnt run this game.

    That is until you just posted this. Ive been playing B&W for the last 3 hours and I love this game! Thanks Again!
     
  7. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #7
    Cheers mate! Enjoy the game. :cool:

    PS: Forcing games to run in 32-bit colour will usually allow games to work on Macs with the GMA X3100 integrated graphics. Search the usual suspects: *.plist, *.ini, for a setting to change display bit-depth.
     
  8. dnaytch macrumors newbie

    Joined:
    Aug 12, 2008
    Location:
    New Jersey
    #8

    I don't understand how to do this. I try to open the application black & white, get the 800x600 resolution message, and when I click ok, the program quits, so I don't see when or where I can change these settings. Any further help with this would be appreciated because I used to play on my ibook years ago, and I suddenly got the urge to play again. :p
     
  9. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #9
    Ah, sorry for sounding technical in my post. The steps are not simply point-and-click, you will need to edit the configuration file. Let me try to clarify:

    First open this file using TextEdit:
    ~/Library/Preferences/Lionhead/Black & White/Preferences Data

    Go open your Home folder. It is in the Startup disk, inside the Users folder. Your Home folder is named with your short user name. Then navigate down the other folders listed (Library/Preferences/Lionhead/Black & White). Next open the file "Preferences Data" using TextEdit.


    Find the line that reads:
    <value name="ScreenD" type="integer">16</value>

    Search for this line in the Preferences Data file you just opened in TextEdit.

    Then change 16 to 32.

    Save the file.

    Launch Black & White.


    Hope this helps. :)
     
  10. edddeduck macrumors 68020

    edddeduck

    Joined:
    Mar 26, 2004
    #10

    Absolute genius!! Thanks for that, I have asked our support guru's to update our replies with your cunning fix.

    Cheers,

    Edwin

    Feral Interactive
     
  11. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #11
    You're welcome. I'm glad it helps. :)
     

Share This Page