BlackBook boots into weird "Terminal"

newmacchick

macrumors member
Original poster
Jul 10, 2007
48
0
My friend's BlackBook has been booting into this weird version of Terminal. When you boot the computer, you have to hold down the power button and then you get the normal white screen, followed by the Apple logo and the little status circle that shows that the OS is loading. But then it goes right into a black screen and in the upper left hand corner is an erratically blinking white rectangle. Then I tried pressing keys a couple hours later and realized that I could get letters to appear, though the letters would soon be wiped out by the rectangle. I can't really type anything or any commands. I tried resetting the PRAM and I did the method whereby you take the battery out and then press the power button for five seconds, but that didn't do anything either.

Before my friend had this problem, she was trying to get onto another college's wireless network; it said she didn't have authorization because she didn't have a program, and she was in the middle of installing the program ("error installing program"), so she force quit the program. Before she force quit, she tried Firefox and it wouldn't connect to the internet. Then she restart her computer and it was like this.


Thanks,
newmacchick
 

Hockeypuck

macrumors regular
Sep 29, 2006
102
0
Try booting from her install CD and doing an Archive and Reinstall, sounds like something is messed up with the OS.
 

dacreativeguy

macrumors 68020
Jan 27, 2007
2,014
210
This happened to me after a bad upgrade back in the panther days. Just do an archive and install from your tiger dvd and then software update to current. You may have to reinstall a few apps that store data in the system library, but other than that you'll be back up and running.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.