Blackra1n- The Gliches, Troubles and Triumphs

Discussion in 'Jailbreaks and iOS Hacks' started by applefool, Dec 7, 2009.

  1. applefool macrumors member

    applefool

    Joined:
    Mar 4, 2009
    #1
    It would be great if we could a get a forum going just discussing the various aspects of the latest jailbreak for the 3.1.2 firmware, aslo known as blackra1n:

    If you have used blackra1n, you know that it is the easiest jailbreak to date without question. However, its new and it definitely has its kinks...

    So far, blackra1n hasn't caused me any real problems except the occasional wifi glich. I'm working with several iPhones here. Often times after running blackra1n everything works fine. However, other times after the jailbreak I have problems identifying wifi networks. This problem is fairly simple to fix:

    Go to Settings - General - Reset - Reset Network Settings

    Then hold the pwr and home buttons for three seconds to reset again after reboot. This will usually fix the problem identifying wifi networks. Youtube also seems to be a bit of an issue. The above method doesn't always work for youtube and I still haven't found what consistently does.

    After running blackra1n, there should be a black raindrop logo on the second page of your applications labeled blackra1n. From here you can install sn0w, the unlock installation. (The first time I ran blackra1n though, after the frodo reboot my springboard was completely black... I DIDN'T HAVE A SINGLE APP. I simply restored again and repeated the process. It worked fine.)

    Sn0w seems to be a bit finicky as well. Things to remember: go to setting - network and disable the 3G option. The T-Mobile unlock will not work for me unless I do this before the sn0w installation.

    Please add anything and everything related to blackra1n to this forum. Post any notes, thoughts, concerns, issues or experiences.
     
  2. Vandam500 macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #2
    I haven't noticed any types of problems with blackra1n. As far as the wifi problem, the developer has already stated he is 100% sure that it's Apple's OS and not blackra1n itself.
     
  3. veedow macrumors newbie

    veedow

    Joined:
    Dec 19, 2008
    Location:
    Chicago suburbs
    #3
    Very happy with the jailbreak using Blackra1n. The only issue I have with my 3GS is posted in the Troubleshooting Forum: Podcast, select more sources...launches safari???

    http://forums.macrumors.com/showthread.php?t=826787

    The phone is having trouble accessing iTunes. From both, the ipod area and same thing when using Shazam, and clicking on iTunes. Instead of opening in the app, Safari is launched, with an error message.

    This is a minor issue, but would like a fix. Wifi and everything else on the phone is fine.
     
  4. rkdiddy macrumors 65816

    rkdiddy

    Joined:
    Mar 19, 2008
    Location:
    OC Baby!
    #4
    I had the wifi issue as well but was able to fix it.

    The only thing I don't like is if you need to turn off the phone or soft reset - you have to use the software again to unlock it.

    Is there a way around this?

    EDIT: I know this is a built-in feature - but a PITA when you don't have a computer with the unlock software on it and your battery dies.
     
  5. Dr-Ludvig macrumors newbie

    Joined:
    Dec 2, 2009
    Location:
    Denmark
    #5
    Haven't had a single problem with it, very happy with blackra1n! Really easy to use!
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    This applies only to people with the new version of iBoot. Until and unless someone comes up with a new exploit for iBoot, then no, there is no way around it.
     
  7. rkdiddy macrumors 65816

    rkdiddy

    Joined:
    Mar 19, 2008
    Location:
    OC Baby!
    #7
    Ah - I didn't know that. Thanks for the info.
     
  8. iphonegeek786 macrumors 6502

    iphonegeek786

    Joined:
    Nov 18, 2009
    #8
    I was stuck on the Recovery screen every time I ran it, but I found out that I hadn't updated,:D, smooth sailing from ther!!!!
     
  9. MentalZS macrumors newbie

    Joined:
    Dec 6, 2009
    #9
    I had decided to Jailbreak my iphone 3g and everything went well as in running blackra1n program, then seeing geohutt, then reboot so all done on the installing side.

    Problem i have now is, when i go into my iphone, there isnt a Blackra1n icon anywhere to say its been installed onto phone yet my computer said its installed successfully. So where could the icon have gone?
    Is there a way round this?
    Do i need to install again?

    Like i said, everything worked fine for the installation and phone re-booted as normal but then no blackra1n icon on phone. Still not sorted it out yet, any help much appreciated!
     
  10. applefool thread starter macrumors member

    applefool

    Joined:
    Mar 4, 2009
    #10
    yeah, just do it again

    I had the same problem. Ran blackra1n and everything was straight, then when I booted the app was nowhere to be found. I restored back to the latest firmware update and ran blackra1n again and the app was there. Sometimes these hacks are finicky. Just restore and got through the process again and you should be fine. :)
     
  11. applefool thread starter macrumors member

    applefool

    Joined:
    Mar 4, 2009
    #11
    I originally started this forum because I was having trouble getting a good signal after running blackra1n. I can finally say, that this was not due to blackra1n. This has shown to be the product of a faulty pin in the sim card slot. Been running blackra1n on a new 3G today and its been perfect. If you love blackra1n as much as I do, please contribute to the hackers.... without them we would all be helplessly bound to atnt.
     
  12. Vatche macrumors member

    Joined:
    Feb 21, 2009
    #12
    Been using it since day one on my 16G iPhone 3GS with no issues what so ever!! I love it.:)
     
  13. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #13
    Hacker, you mean. Blackra1n and blacksn0w are completely the product of a single college freshman named George Hotz. It's his picture that graced your phone during the jailbreak process.
     
  14. ckong macrumors regular

    Joined:
    Nov 12, 2009
    #14
    I'll add my $0.02...

    My blackrain experience was not as smooth as others. The 3 minute JailBreak took me over 4 hours to do. I won't bore you guys with my tries/re-tries in XP/Vista-32/Vista-64, the number of iTunes installations done (to get the right drivers), or the numerous restores of my iPhone.

    This ended up working for me:

    iPhone 3GS-32Gb w/ firmware 3.1.2
    blackra1n.exe (rc2) running
    iTunes 9.0.x
    Vista 64-bit

    To JailBreak:
    Exit iTunes.exe (if it's running) and stop the iTunesHelper.exe process from the TaskManager (Ctrl-Alt-Del)
    Run blackra1n.exe natively (note: not XP-compatibility mode)

    I initially got only as far as BL putting the iPhone in DFU mode. Blackra1n would then say it was waiting for the iPhone. Only after making sure iTunes.exe wasn't running, killing the iTunesHelper.exe process, and running blackra1n.exe natively did it continue.

    I know. I know. Lots of guides say to run BL in XP-compatibility mode as Admininstrator. It didn't work for me. Some guides also say to additionally kill the Bonjour service. I didn't need to. I also found out that I didn't need to restore the iPhone each time it was in DFU mode. Blackra1n puts the iPhone in DFU mode to begin with, so towards the end I just kept trying combos with the iPhone sitting constantly in DFU mode.

    In retrospect, the key to doing it for me was to have the right combo of OS/drivers running/settings. This was my very first time JailBreaking an iPhone. An exciting experience to say the least (after wondering if I bricked my phone multiple times). Maybe next time, it really will take 3 minutes...

    P.S. In thanks to this marvelous program blackra1n, I donated to GeoHot.
     
  15. DazBrowne macrumors member

    Joined:
    Dec 6, 2009
    #15
    Ive had the wifi issue - my way to solve is
    1) Turn Airport mode on
    2) Turn WiFi on
    3) Reboot
    4) TaDa!!
     
  16. Deucerok macrumors newbie

    Joined:
    Dec 11, 2008
    #16
    My personal glitch

    I've got a major issue going on right now where most of my jailbroken and native apps work, but other iTunes apps are failing upon startup.

    Essentially,
    1. I choose the app,
    2. It begins to boot
    3. A screen for the app shows up for less than a second
    4. Then returns to the home screen.

    Aside from that, everything works perfectly. I tried to troubleshoot the issue by doing a re-install, but it didn't eliminate the issue. I'm using AT&T still, so I didn't need to use blacksn0w. Any one else seeing this??

    -Deuce.ROk
     
  17. Skinnimimmy macrumors newbie

    Joined:
    Dec 10, 2009
    #17
    Issues with BlackRain

    Working with iphone 2g on 3.1.2. on Macbook.

    First download, got Blackrain, but when I opened it, no Blacksnow. I downloaded Ultrasnow through Cydia, and that did not unlock. I downloaded Bootneuter thru cydia, ran that, and am partially unlocked. I have the SIM card from TMobile in the phone and can only receive incoming calls. The screen is stuck on the itues logo, and when I connect to itues, it says I have an incompatible SIM card. I did update itunes before starting this process.

    Any suggestions?
     
  18. Harmush macrumors 6502a

    Harmush

    Joined:
    Sep 21, 2008
    Location:
    Liverpool
    #18
    no 3G connection

    I jailbreak/unlocked with blackrain and snow from the blackrain app icon. but i am not getting a 3g connection on my iphone3g. All i can see is the little circle but never a 3g icon. I did get 3g for about 3 seconds before but i've never seen it appear since. any idea of how to fix.
    I'm using it on Orange UK.

    any suggestions, really would like to have 3G
     
  19. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #19
    hey thelatinist you sound like you are related to GeoHot...better still perhaps you ARE him!! Kidding :cool:

    Anyhoo i must admit that the blackra1n software is probably the easiest way to jailbreak the iphone than using the dev team methods (redsn0w) however i did encounter a few problems...

    Having the iphone 3g I lost the use of the wi-fi (in which may have been a hardware problem more than a software problem!) after installing ra1n & sn0w it works ok for the first week however i did notice that the battery was draining rapidly so decided to remove sn0w (via Cydia) as i didnt have the need for it and that was when the wi-fi decided to "stop" working! just a coincidence!

    Lucky the iphone in question was still under warranty therefore it was replace by apple (after restoring and setting up as a new iphone!) and i now have a (quite possibly "reconditioned") new iphone with the latest firmware 3.1.2 BB 05.11.07 etc already installed.

    Having this "reconditioned" iphone only ra1n was used to jailbreak the iphone but this time I decided to leave out sn0w as my iphone is now officially unlocked thanks to O2-UK :) wi-fi works just dandy but now the GPS has intermitting problems!! Intermitting problems meaning that maps was showing that i was driving on a field in the middle of nowhere randomly zooming out and in, the blue circle stops pulsing etc! *sigh*

    Performed another restore using itunes ipsw to remove ra1n etc and GPS started to work again! Decided to leave it for a few days before installing ra1n and maps stopped working!

    So before i say ra1n has not been good for me and before anyone starts defending ra1n and saying i am an idiot :p i am going to get this "reconditioned" iphone replaced for another "reconditioned" iphone stating my case that the GPS does not work and then i will make another attempt using ra1n and if all else fails...i think i will buy an iMac or wait patiently for sn0wbreeze ;)

    My opinion….3.1.2 sucks and wishing I haven’t upgraded from 3.0.1 (JB on redsn0w) and I shudder to think what apple version 3.2 will have in store in terms of jailbreaking....
     
  20. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
  21. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #21
    So you did not have to reset network settings? I've been looking for a way to fix the problem without losing all my saved networks. I've only had the problem twice, but it's always a pain to have to reenter networks and passwords.
     
  22. iphone3gsdead macrumors newbie

    Joined:
    Dec 11, 2009
    #22
    blackra1n bricked my phone

    OK so i ran blackra1n on my 3gs and it got stuck in entering recovery mode. So i closed blackra1n (after waiting about 15mins) and restarted blackra1n program to run again. Now my phone is unresponsive, computer doesnt recognize it ( no chime when plugged in with usb) neither does itunes. I dont know what to do now... i tried holding down the home and power button and all that stuff still nothing. Seems blackra1n bricked my iphone.....help!!
     
  23. mkw macrumors newbie

    Joined:
    Dec 12, 2009
    #23
    I had the same problem with my 3GS. But after a few hours with anxiety and sweats, I successfully jailbroke my phone.

    Try these

    • To get you phone back in recovery mode try pressing power button and home button at the same time. (*** You will have to do this several times, if nothing is shown (blank screen) on the phone screen, just relax and do it again). I had to do it over 10 times
    • If you could get your phone back in to recovery mode and when you jailbreak your phone, use an USB port which comes straight out from the motherboard. Try avoid using laptops, instead use desktop computers. I never had a luck with my laptops. I did mine with an old desktop machine

    Good luck!
     
  24. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #24
    your options are simple

    if you like Blackra1n use it, for many it's a great simple program.If you are having trouble & you think is because of it then try the Devteams Pwnage Tool little trickier since it's Mac and takes longer these are the only options right now. Both use different methods of JB both have people very happy with them and both have people unhappy with one or the other. it's your choice both are free to use. Geohot has no plans to work on Blackra1n or Blacksn0w in the immediate future. FYI no amount of complaining about it is going to make him work on it right now. he is sick of people complaining about something he offers free and it's not a priority in his life. ;) So even if you find problems how do you plan to fix them! :p oh and if you don't like either other option is don't JB Apple OS!
     
  25. ihappy macrumors newbie

    Joined:
    Dec 29, 2008
    #25
    I was able to jb using blackra1n on 3 iphones (a iphone and 2 iphone 3gs) without any issues. Helping a friend to jb hers as well, it turns out our phones were from before the dreaded 40 week, hers is week 46.

    Looks like she is able to jb it and tmobile sim works as far as getting a call but can't get to anything else, her screen is stuck on the recovery mode. After doing some reading, it says to leave the tmobile sim in the phone and run blackra1n again and that will bring the phone out of the recovery mode. That didn't work.

    Does anyone have an idea how to get her phone to work on the tmobile network? what else can we try?

    Here are the specs and things we have tried on her phone:
    - upgraded to 3.1.2, 05.11.07
    - serial number 46 (4th and 5th digits)

    Steps we took:
    - restored in itunes
    - got fresh copy of blackra1n
    - disabled 3g network
    - after tmobile connected on her iphone, i called her and the phone rings and able to answer and make calls, but can't get to anything else bc of the dreaded recovery mode screen
    - run blackra1n again
    - reboot - same result

    Helpppp please lol
     

Share This Page