Blackscreen - Display assembley replacement mid 2010 13inch

Discussion in 'MacBook Pro' started by mbp12345, Jul 26, 2016.

  1. mbp12345, Jul 26, 2016
    Last edited: Jul 26, 2016

    mbp12345 macrumors newbie

    Joined:
    Jul 26, 2016
    #1
    Hi, just replaced the display assembly on my mac and currently have a black screen.
    I think i may have damaged the thin piece of foil on top of the inverter but i am unsure if this would cause the screen to be black.

    The replacement display is brand new and i am only replacing it because the previous screen got smashed.

    The screen has flashed once or twice but apart from that it has been black and the apple logo on the back unlit.
    The chime still happens when i switch it on but the button backlights are sometimes on/sometimes off.

    The only other thing worth mentioning is that i had tried to replace the ram cards with a suitable upgrade but was unsure if this could cause problems so reverted back to the original cards.

    Thanks for any advice provided!
     
  2. tubeexperience macrumors 68040

    Joined:
    Feb 17, 2016
    #2
    Check to make sure the display data cable and socket is not bent or misaligned in any way.

    They are both very fragile.

    [​IMG]
     
  3. mbp12345 thread starter macrumors newbie

    Joined:
    Jul 26, 2016
    #3
    Thanks for the reply. The cable and socket are not bent or misaligned. The gold colour foil on top of the socket has came off though, so don't know if this could cause issues.
     

Share This Page