Blackscreen Iphone 3GS bricked

Discussion in 'iPhone Tips, Help and Troubleshooting' started by yoance, Feb 13, 2011.

  1. yoance, Feb 13, 2011
    Last edited: Feb 13, 2011

    yoance macrumors newbie

    Joined:
    Feb 13, 2011
    #1
    i have a Iphone 3GS with 3.1.2 firmware

    it was tethered jailbroken with blackra1n and unlocked, so i tried to use redsnow to upgrade it to 4.2.1, but now i have a phone that has a blackscreen, i tried the hard reset over and over again and it just does not work.

    the pc usb chimes when i connect it, and itunes says its in recovery mode but when i try to update it i get an error, i researched the code and it states that itunes cannot get the phone to boot.

    is there any software that can get this phone to boot, my fear is that when the battery dies i wont be able to do anything with the phone.

    one more thing, greenpoison is the only thing that as gotten the phone to do anything, a white screen then when i try to get it into recovery mode it goes back black. even if i just touch the sleep mode it goes back blackscreen
     
  2. yoance thread starter macrumors newbie

    Joined:
    Feb 13, 2011
    #2
    update on my problem

    ok so i did a restore with 4.1.2 fw

    not i need to get past this request for att simcard, how do i do that without a simcard?

    i want to unlock the phone
     
  3. Boereman macrumors member

    Boereman

    Joined:
    Jan 1, 2011
    Location:
    Port Elizabeth, South Africa
    #3
    ok.

    1) You're not bricked. iPhone's cannot be bricked easily from what I've seen, done and heard.
    2) Try using Recboot and then jailbreak with redsn0w.
    3) As for the unlock, you will need to install the iPad BB and then use wifi to download ultrasn0w
     
  4. LucasG macrumors regular

    LucasG

    Joined:
    Aug 4, 2010
    #4
    To hacktivate it you will need to install the iPad baseband as you probably have 5.14.04 baseband which is not unlockable. Once you've done, you just use redsn0w to hacktivate it and then greenpois0n to get an untethered jailbreak. :)
     
  5. yoance thread starter macrumors newbie

    Joined:
    Feb 13, 2011
    #5
    problem solved

    thanks guys.


    Recboot was not kicking it out of the black screen though.

    *i downloaded the custom iPhone2,1_4.2.1_8C148a_Restore.ipsw
    *then i used itunes to to install the custom ipsw, by holding down the shift button (because i am using a Windows OS) and selecting the ipsw.
    * To prevent having a tethered JAilbreak i ran greenpoison first, then i used redsn0w_win_0.9.6b6 to jailbreak as u told me with the ipad base band
    *then i downloaded ultrasnow using cydia over wifi.
    *then restored my back up files and stuff via tunes.
    thank God i got my phone back.


    N.B. Recboot was just not working......that's why i had to do the restore from itunes. thanks again guys. hope my method helps someone having the same problem. Tell me if i included any unnecessary steps by the way.
     

Share This Page