Blinking folder icon with question mark on Yosemite, but I need some files back!

Discussion in 'OS X Yosemite (10.10)' started by bedridden, Sep 9, 2014.

  1. bedridden macrumors newbie

    Joined:
    Sep 9, 2014
    #1
    I have a MacBook Pro mid 2012, and I have installed Yosemite Beta when it was released. It was working fine till yesterday when suddenly the system hung up. After a restart it crashed again and during next restart it showed that the error was with launchd process failing or something like that. When I restart it again, it doesn't show the Apple logo, but it now shows the blinking folder icon with a question mark, like this.

    [​IMG]

    Here's the thing: I have some files in the system I want back at any cost. I don't have time machine backups... I needed some space and I used the time machine disk for that. It hurts now... :/

    It looks like my recovery partition doesn't exist at all as nothing comes up when I restart with Cmd + R pressed.

    If I try booting with alt key, this is what it shows:

    [​IMG]

    Tried a NVRAM/PRAM reset, and didn't work. When I connect to a network and try Internet recovery (which I am not sure whether I should do or not if I want my files back), it shows this:

    [​IMG]

    I have tried booting from Ubuntu live USB (which was readily available), but then it doesn't even show the Mac disk among those partitions. Only the live USB shows up as /dev/sda, but there's no /dev/sdb or anything at all. It acts like theHard disk is not connected at all?

    How can I fix this? My number one priority is to get my files back, and then reinstall OS X. I have a Mavericks image, a USB drive and another laptop with Linux and Windows in it. Any ideas?
     
  2. Small White Car, Sep 9, 2014
    Last edited: Sep 9, 2014

    Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    Not gonna lie, the fact that the drive didn't show up when Ubuntu was loaded is troubling.

    But I'd still try target disk mode next.
    http://support.apple.com/kb/PH10725


    It will require you to find a friend with a Mac and use a firewire or Thunderbolt cable between the two Macs. I wish I knew of a way to do something with your windows machine but target disk mode from Mac to Mac is the most surefire way I know to power through big problems. It'll be worth the hassle.

    (A genius bar appointment can also do the trick if you know of no other Macs near you.)

    The 2nd thing I'd try is to make a bootable OS X USB drive and load it on your computer:
    http://www.macworld.com/article/236...otable-os-x-10-10-yosemite-install-drive.html

    (May need the friend's Mac to make that too.)

    This is basically a real-world recreation of your recovery drive that won't load. Once that's loaded run Disk Utility from the USB drive and see if it can repair anything.

    But target disk mode is safer. I'd really want to try copying stuff off that way before I tried any kind of repair.
     
  3. bedridden thread starter macrumors newbie

    Joined:
    Sep 9, 2014
    #3
    True that! Nothing gets mounted as read only like HFS partitions normally do, and even with hfs utilities installed, I can't find the drive itself. Nothing shows up in fdisk -l and GParted shows only live USB as the existing disk. Strange.

    And that makes me wonder how the OS X bootloader being loaded initially, if the HDD can't be found at all...?

    I am from India, and I don't think we have Genius appointments here? I have a friend who has a newer MacBook pro, but using the target disk mode means I would have to get a Thunderbolt 1 - Thunderbolt 2 connector. His model doesn't have firewire, but I think a Firewire-Thunderbolt connector can be used too.

    Speaking of which, these connectors aren't the cheapest... :p

    I should thank you a LOT. Seriously, I had NO idea what to do before I read your post. Thanks a lot!

    I wonder what Apple support would do if I call them after trying all this... I don't think they assure our data safety.... Do they?

    Guess I shouldn't have got too excited about Yosemite. Didn't like it much either... liked Mavericks a lot... :(
     

Share This Page