"blinking" hard drive icon, finder won't open, but only on one account

Discussion in 'macOS' started by kant, Apr 23, 2008.

  1. kant macrumors 6502

    Joined:
    Jul 22, 2004
    #1
    15" MBP Penryn, 2.5ghz, 250gb 5400rpm drive, 4gb ram.

    Trying to switch from my main account to one of the other user accounts. The account starts to load, the menu bar comes up, then the hard drive icon starts slowly blinking. The menu bar disappears with it unless I open a program from the dock. Can't open a finder window. Even with another program open, when the hard drive icon shows back up, the non-existent finder window steals focus until it disappears again. Only way I can get out is to hit the power button, click restart, then click switch user.

    Tried rebooting and repaired permissions. Still does it. That's pretty much the end of my Mac trouble shooting skills.

    If I switch to either of the other two user accounts, they load just fine.

    The last time I tried switching to the problem account, the fans ramped up loudly. In the few seconds it took to switch back to the main account iStat said the CPU was 85 degrees and the fans were 6700 rpm. I usually run 65/2000 (which I understand is a tad high anyways, but that's another subject.)

    So, what's wrong and how do I fix it?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Well, I can guess what's wrong, anyway: Sounds like the Finder is crashing as soon as it loads. That's why the hard drive icon and menubar disappear--they go off every time it crashes, and reappear when it tries to automatically re-launch.

    As for fix, not sure; the two obvious culprits would be that you had something open before that causes the Finder to crash, so now every time it tries to load with that window open, it re-crashes, or a corrupt preference file.

    The solution to both may be the same: Delete the Finder's preference file so it gets re-created, and doesn't open whatever it's trying to.

    To do that you'll need to use another user with admin privileges to get to the problem user's preferences folder (in their home Library), locate com.apple.finder.plist (there may be other files as well... not sure), and delete it.

    Hopefully that gets Finder to launch properly.

    [Edit: Could also be something on the Desktop causing the crash, in which case this MacOSXHints hint applies: http://www.macosxhints.com/article.php?story=20060308010111601 ...try that if the plist deletion doesn't do it.]
     
  3. andy.barron macrumors 6502

    Joined:
    Nov 30, 2006
    Location:
    Bedford, England
  4. kant thread starter macrumors 6502

    Joined:
    Jul 22, 2004
    #4
    Ok, this is really starting to be un-amusing. I tried the suggestions above and they didn't work, so I deleted the user account and made a new one.

    Same thing.

    So I deleted that account and created another one with a different name.

    Same thing.

    And now it's doing it on the other existing user accounts, but NOT on my main account.

    Does time machine offer an option to take the entire system back a week like the old windows program GoBack?
     

Share This Page