Blinking Question Mark and Much Much More

Discussion in 'Macintosh Computers' started by Jo Slade, Dec 8, 2004.

  1. Jo Slade macrumors newbie

    Dec 8, 2004
    Victoria, BC
    I have an iMac DV SE running OS 10.2.8.

    I would like to try a few things before resigning myself to pouring yet more money into this computer. I can't afford a new computer and this one has already been given a new motherboard and logic board. I am sick of giving it gifts, so don't want to give it a new drive unless I absolutely have to.

    The problems are many, but I think if I could just repair permissions, things might improve. However, I cannot repair permissions at this point because the hd icon does not appear as an option in disk util. Nothing shows up at all.

    So, I tried repairing permission on console with sudo diskutil repairpermissions / which gets me this message: DiskArb couldn't be activated!

    I booted from the install CD, and ran disk util which got me this message:
    Volume check failed.
    Invalid parent CName in thread record.
    Missing thread records (with a list of about ten missing records given)

    Tried single mode fsck -y at console, get the same results.

    Safari disappeared totally after a crash. In the dock and in the applications folder, there are generic folders marked 'Safari' but they are empty. A 'find' search finds nothing except the Safari crash reports, but the final and fatal crash isn't listed. I thought this might mean a bad block, but instead of just being gone, the empty generic folder is there instead.

    I logged in as another user, same problems occur.

    Attempts to install any new programs (such as Macaroni) in the hopes of running permissions repairs another way fail with an error 32, broken pipe

    I wonder about Cocktail, whether it might be an issue here, I installed it recently and was using it to repair permissions, etc., but now the trial period is over and suddenly I cannot access the drive to run permissions through disk util.

    I ran sudo sh /etc/monthly, weekly and daily checks manually on the console. The results from the monthly ones are bizarre, and QT gets mentioned a lot. I could post it if it might give a better idea?

    Perhaps the weirdest thing is, other than these events, the system is actually running quite nicely, it isn't slow, it isn't having unexplained crashes or freezes, etc.. How bizarre is that?

    Thanks, if you can help with some tips, it would be hugely appreciated. I feel like a real dork for signing up to a new forum and immediately tossing out a big whackin' problem like this, but I am quite new to the whole Unix-based way of life. I love it, but am not very efficient at troubleshooting things yet.
  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Based on the errors you're mentioning, it sounds like your drive is a total disaster, and I'm surprised it's booting at all.

    If starting up from the install CD and running Disk Utility doesn't fix things (remember to try more than once, though), then fsck likely won't, either, since they theoretically use the same routines.

    Frankly, though, it sounds like your directory structure or other drive business are pretty badly screwed up, so your best bet would be to back up the important stuff and totally reformat the drive, then re-install the OS from scratch and put your stuff back on. I know this is a hassle, but if things are that bad now, it's probably only a matter of time before things fail completely.

    Just be glad if it's not a hardware problem (though are you sure it's not? this sort of thing can be a symptom of a failing drive). Definitely important to be backing up things now, just in case. If it runs fine after a reformat and reinstall, maybe you're ok, but be particularly dilligent about backups and keep your eyes open for more signs of trouble that would indicate the problem is the drive.
  3. Jo Slade thread starter macrumors newbie

    Dec 8, 2004
    Victoria, BC
    To be honest, I think it is only booting because it is scared stiff of me. :cool: I've said some pretty hostile things to it. Then again, maybe that's why it is failing....

    Seriously, thank you for getting back to me, I basically know in my heart that it is the drive, I just wanted to make one desperate last attempt to see if it might be something else. The reformating is a thought, but your comments about a failing drive pretty well match the comments of the local techie. I just have to pull myself out of denial, back up my stuff and say goodbye to some cash.

    I truly wonder if there is such a thing as a lemon, a 'Monay' model, in the computer world. I've had two macs before this, and never a problem close to what I've had with this one. Thanks again.

Share This Page