Blizzard downloader killed my mac

Discussion in 'Mac Basics and Help' started by red2d2, Sep 3, 2008.

  1. red2d2 macrumors newbie

    Joined:
    Oct 24, 2006
    #1
    Hey folks,
    Just decided to watch the trailer for the new WOW expansion Wrath Lich King (I no WOW is for freaks but the new trailer really looks epic!). For some reason on Blizzards website when u download the movie you have to download a .dmg which opens a p2p downloader. I started downloading and went to do somethin else for a min, when i lookd agin my Mbp was powered off.
    I powered back on and it took ages to get past the boot screen and then completely stops at the blue screen just before i should log in.
    I tried a few key combos when booting tried dumping pram but to no avail. Not sure how to resolve this. any help would be greatly appreciated.
     
  2. ebel3003 macrumors 6502a

    ebel3003

    Joined:
    Jun 20, 2007
    Location:
    "The Google"
    #2
    Not sure how this would have been caused by Blizzard Downloader, but I do have one suggestion: try resetting the SMC.

    http://support.apple.com/kb/HT1411

    If that doesn't work, then perhaps you should pop in your OS X boot disk and use Disk Utility to verify/repair your disk and permissions.
     
  3. red2d2 thread starter macrumors newbie

    Joined:
    Oct 24, 2006
    #3
    :(

    Alas i tried both your suggestions and no joy. I tried powering on again in a quieter place and i could hear the hard drive - tick,ticking. so i'm guessing thats whats dead.
    It wont even boot from my os x cd. It must have gotten a knock and the installer i downloaded must have just triggered something when it started writing to the drive. Damn, time for ANOTHER new HD.
     
  4. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #4
    Start up using verbose mode (hold down v while starting up). If it gives you a bunch of I/O errors your hard drive is dead (and the blizz downloader didn't "kill" it :p).
     

Share This Page