Blizzard downloaders

Discussion in 'Mac and PC Games' started by Songokuu, May 5, 2010.

  1. Songokuu macrumors newbie

    Joined:
    May 5, 2010
    #1
    I just tried to download the mac clients. I downloaded the "downloader".. unzipped it.. but when i run it nothing happens. I don't get any errors or anything just nothing happens. My computer is a new macbook pro7,1 and i run the latest version of OS X.

    i tryed SC2 and SC1 and D2 and any downloader wont open


    help pls i have snow 10.6.3
     
  2. LetUsHXCDance! macrumors newbie

    LetUsHXCDance!

    Joined:
    Mar 22, 2010
    #2
    The downloaders are BitTorrent based, so make sure that you're internet allows P2P sharing.

    There is a way to directly download and not use the torrent protocol, I forget where it is though.
     
  3. Songokuu thread starter macrumors newbie

    Joined:
    May 5, 2010
    #3
    its not p2p problem because everything is ok on Windows
     
  4. atarria macrumors member

    Joined:
    Oct 4, 2009
    #4
    check r/w permissions

    Open the information panel of the file, command i, and see how the permissions are set. Might solve your problem.
     
  5. Songokuu thread starter macrumors newbie

    Joined:
    May 5, 2010
  6. QuantumLo0p macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #6
    Are you running LittleSnitch or something similar? Just curious, I know mine has a ton rules for various Blizzard IP addresses since I installed a year ago. You may want to check os-x firewall settings if you haven't already. Perhaps even your router may even be stopping some traffic.

    I am currently using a Linksys wrt54 running dd-wrt firmware and it hasn't blocked any gaming traffic so far. When I was using a Smoothwall router, it blocked almost everything and I had to do a lot of port mapping to let Steam through.
     
  7. diegobgr macrumors 6502

    Joined:
    Nov 22, 2009
    #7
    iMac 4670 owners, please comment gaming performance!

    - Sorry -
     

Share This Page