Block sending/receiving SMS for one contact and use iMessage only?

Discussion in 'iOS 7' started by willryan42, Jul 19, 2013.

  1. willryan42 macrumors regular

    Joined:
    Feb 26, 2009
    #1
    Not sure if this is iOS 7 specific, but I thought it might have something to do with the new "block" feature.

    My girlfriend lives in Australia, I'm in the US. To avoid $.20 per text message, I'd like to only use iMessage when texting her. This works most of the time, but every once in a while it goes through as a green SMS message. I usually make sure to wait until send is blue and it says iMessage in the text field, but it still sometimes goes through as sms.

    I have the "send as sms" toggle turned OFF in iMessage, but this doesn't seem to always work. Is there anything else I can do, or block sms for this one contact only?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    You could remove her phone number, and only have her email address listed, then remove the saved thread to her in Messages, and start a new message thread only using her (icloud) email address. She can also change her setting so that she is also sending to your email address and it would work out for both of you.
     
  3. willryan42 thread starter macrumors regular

    Joined:
    Feb 26, 2009
    #3
    Ahhhh good idea! That actually sounds like it should work, and a pretty simple fix at that. I'll try it out, thanks!
     
  4. imaginex20 macrumors 65816

    imaginex20

    Joined:
    Jun 17, 2009
    #4
    Another idea is to create a second contact for her email only and when you want to iMessage her you send it to that specific contact thus still having her phone number saved to the original contact.
     

Share This Page