blue screen after changing mainboard hdd and upgrading ram

Nayyar Sultan

macrumors newbie
Original poster
Nov 12, 2018
2
0
I have a macbook pro 2011 recently I change the motherboard and replace hard drive with ssd with 8 gb ram. Now the problem is that when I turned on laptop it goes to blue screen after some time and with 4gb ram its fine. I don't know what's the problem plz help me.
 

DeltaMac

macrumors G3
Jul 30, 2003
9,528
2,301
Delaware
So you get a blu screen when 8GB is installed?
And, changing to 4GB, it boots and works fine?

That's not too difficult. One or both of the RAM sticks for 8GB are faulty, or are not quite compatible with your MBPro.

Or - could be the logic board... Why did you replace that? Was it graphics or video problems?
If you have either a 15 or 17-inch model, that's a pretty common issue, and a replacement logic board may not necessarily fix any graphics issues on a 2011 model.
If the RAM is the issue, then consider that any 2011 model can be upgraded to 16GB (2 x 8GB), but, I'm not sure about spending that much on a 7 or 8 year-old laptop.
 

Nayyar Sultan

macrumors newbie
Original poster
Nov 12, 2018
2
0
So you get a blu screen when 8GB is installed?
And, changing to 4GB, it boots and works fine?

That's not too difficult. One or both of the RAM sticks for 8GB are faulty, or are not quite compatible with your MBPro.

Or - could be the logic board... Why did you replace that? Was it graphics or video problems?
If you have either a 15 or 17-inch model, that's a pretty common issue, and a replacement logic board may not necessarily fix any graphics issues on a 2011 model.
If the RAM is the issue, then consider that any 2011 model can be upgraded to 16GB (2 x 8GB), but, I'm not sure about spending that much on a 7 or 8 year-old laptop.
Mainboard has been changed because of some damage slots
[doublepost=1542183206][/doublepost]Y
Mainboard has been changed because of some damage slots
Ou mean I have to check and change (2x4gb) to (2x8gb) ram
[doublepost=1542183362][/doublepost]
Mainboard has been changed because of some damage slots
[doublepost=1542183206][/doublepost]Y
Ou mean I have to check and change (2x4gb) to (2x8gb) ram
Both of the ram should be ok because its work fine before changing hdd to ssd
 

DeltaMac

macrumors G3
Jul 30, 2003
9,528
2,301
Delaware
But - did you try now with the old (2 x 4GB) RAM? and does that work?
Then, swapping to the new (2 x 8GB) RAM, and you still have problems?