Blue Snowflake mic won't show up in Logic Express 8

Discussion in 'Digital Audio' started by lord patton, May 22, 2008.

  1. lord patton macrumors 65816

    lord patton

    Jun 6, 2005
    I just got a Blue Snowflake. It shows up in System Preferences and GarageBand, but not Logic Express 8. The only device showing in Logic's preferences is "built-in audio".

    Any idea why? I'm running 10.5.2 on the 'puter in my sig.
  2. lord patton thread starter macrumors 65816

    lord patton

    Jun 6, 2005

    The tech support at Sweetwater just called me back (responding to my email—in under 30 minutes!) and solved the problem.

    Logic requires an audio device to have an output. The Snowflake doesn't. So the trick is to create an aggregate device via the Audio-Midi Setup Utility (it's under the Audio menu in the menu bar). Select both the Snowflake and Built-In Audio (or output device of your choosing) and there you go. Logic sees the new aggregate device and all is well.

    I'm damn impressed with Sweetwater, by the way. Their customer service is as good as can be.
  3. AviationFan macrumors 6502a


    Jan 12, 2006
    Cedar Rapids, IA
    I've heard a lot of good things about them. So far, I've never really had a problem that required any of their fantastic service, but your experience seems to confirm the word on the street.

    - Martin
  4. PooeySK macrumors newbie


    Jan 13, 2006
    Just because I am a dork, the above instructions weren't 100% clear, and it took me some while to make it work. For my fellow dorks, here is some additional details.

    1. The Audio-Midi Utility is the one included in Mac OSX under applications>utilities (I was trying to find it elsewhere, like within Logic, or the Sound menu in Sys Prefs--ugh)

    2. The "audio devices" tab must be highlighted, and the audio menu is up at the very top of the screen.

    3. You must select BOTH the snowball mic (or in my case, the Samson CO1U) AND the Built-in Output. The aggregrate device didn't show up when I only had the mic selected.

    I know this may seem utterly obvious to some of you, but hopefully it helps the rest of you!
  5. asjoh macrumors newbie

    Jul 14, 2009
    Logic don't show the aggregate device

    Thank you for those instructions. but they don't really work for me.

    I have done an aggregate device this way:

    1. Aplications/utilities/Audio Midi setup.
    2. shift+command+A.
    3. then I choose The samson C01U and internal Input.
    4. Set the "clock" to my microphone.

    But Logic doesn't show my aggregate device. What's wrong?

    Shall I mark the Internal output too? And where shall the "clock" be set.

    P.S. I have an Imac.

    What am I doing wrong?

    Thank you
  6. lord patton thread starter macrumors 65816

    lord patton

    Jun 6, 2005
  7. vovoclock macrumors newbie

    Aug 30, 2009
    I'm having the similar trouble with the snowflake the only difference I can think of in this scenario being that I am using Logic Studio. But I have tried all the suggestions mentioned here. I have gotten the aggregate device to show up in the default input (in the Audio MIDI Setup) and the snowflake shows up there too, but I can't get a signal! I'm at a loss. The snowflake is new and it totally works in garageband automatically. What have I missed?
  8. lord patton thread starter macrumors 65816

    lord patton

    Jun 6, 2005
    I assume you've tried selecting the aggregate device in Logic's preferences?

    preferences-->"audio" pane-->"devices" tab-->"Device" selection pop-up
  9. bobright macrumors 601

    Jun 29, 2010
    Lord, did you ever get things going within Logic what was the solution? I realize this thread is very old but I am running into this same problem in trying to set up my Samson USB as an aggregate device so it is picked up by Logic Pro X.

    I have tried everything, have set up an aggregate device, and set it within the audio preferences. It shows up but I am getting no signal as you can see. It works fine in Garageband so not sure why it isn't working in Logic. Any ideas guys what am I doing wrong here (it looks like such)? Does drift need to be check marked?

    Attached Files:

Share This Page