Bluefish 2.2 Problems with Shift Key

Discussion in 'Mac Apps and Mac App Store' started by ejket, Mar 16, 2012.

  1. ejket macrumors newbie

    ejket

    Joined:
    Sep 7, 2008
    Location:
    Canada
    #1
    I bought a new Air the other day, and I can't get Bluefish to work properly. When I hit a key combination like Shift S to get a simple capital S, I get some stupid popup form for CSS. This makes the editor unusable, since I obviously need to type in capital letters.

    I tried some older versions -- 2.03 doesn't even load, and 2.0 and up give me the same problems as 2.2. I have Bluefish 2.03 working on my old MacBook, though.

    Anyone know of any solution for this problem?
     
  2. adelwich macrumors newbie

    Joined:
    Mar 30, 2012
    #2
    Arggggh. I have the *exact* same problem. Did you ever find an answer?

    How is it possible that we are the only people to complain about this problem? Why on earth would they make Shift-S a keyboard shortcut in their text editor? What were they thinking?
     
  3. ejket thread starter macrumors newbie

    ejket

    Joined:
    Sep 7, 2008
    Location:
    Canada
    #3
    No, I'm afraid I never did find a solution. I ended up using Emacs to edit HTML files, though I haven't managed to set a proper default font size with it on a Mac. I'd still like to use Bluefish if I could, since I use it a lot on Linux, and it serves my needs very well.

    I'm still hoping that someone who knows the solution will appear :)
     
  4. pinkpearl macrumors newbie

    Joined:
    Apr 16, 2012
    #4
    I solved this problem. Close BlueFish and edit the file
    ~/.bluefish/menudump_2.

    Replace this line:

    ;(gtk_accel_path "<Actions> /htmlbarActions /DialogsCreateStyle" "<Shift> <Alt> s")

    with:

    (gtk_accel_path "<Actions> /htmlbarActions /DialogsCreateStyle" "")

    Save and open BlueFish. Now the shift+s writes S! :)
     
  5. adelwich macrumors newbie

    Joined:
    Mar 30, 2012
    #5
    Thank you so much! This solved the problem for me.
     
  6. ayh123 macrumors newbie

    Joined:
    May 4, 2011
    #6
    I am running into the same problem, but pinkpearl's method did not work for me. Even after I deleted the accelerator keys for DialogsCreateStyle in the menudump_2 file, Bluefish defaulted back to Shift+S opening dialog. This was the case even though I quit Bluefish, saved the menudump_2 file, and re-opened Bluefish.

    When I open the menudump_2 file, it is still modified the way I wanted it to be; it just doesn't seem to have any effect on the dialog. If I go to Preferences and choose "Reset accelerator keys," the menudump_2 file lists the Shift+S command again, so I know the file is connected to Bluefish.

    I am running Snow Leopard, not Lion. Don't know if that affects anything.

    Thanks for any help.
     
  7. pinkpearl macrumors newbie

    Joined:
    Apr 16, 2012

Share This Page