Bluetooth A2DP trigger delay - affects navigation and other apps - please comment

Discussion in 'iOS Apps' started by sailmac, Sep 9, 2010.

  1. sailmac macrumors 6502


    Jan 15, 2008
    Background: A bluetooth device must detect a preset amount of A2DP audio stream to trigger open a gate allowing the stream to actually play through the device. For users, this means roughly 1 to 2 seconds of audio can be lost at the beginning of a stream. The gate closes a short period of time after the audio stream terminates. Audio content is lost each time the gate must be triggered open. According to Apple, the trigger threshold is controlled by the bluetooth device manufacturer.

    The trigger delay can be a significant problem for navigation apps with text-to-speech (TTS) enabled.

    An instruction spoken via the iP4's built-in speaker has no delay and sounds like, "In one mile at the T junction turn right onto First Street."

    But the same instruction over bluetooth loses words and becomes, "…tion turn right on First Street."

    If something holds the gate open -- for example streaming background audio by iPod or Pandora -- then when a navigation app interrupts with a TTS instruction none of it is lost.

    On the Jawbone ICON I can hear faint clicks at ~ 1 second (gate triggers), ~ 2 seconds (gate is open), and then after a stream terminates at ~ 5 seconds (gate closes). I have listened carefully and the trigger delay affects iPod, Pandora, YouTube, Netflix, Phone -- any app that can generate audio streams sendable to the bluetooth device.

    I'm hoping to get the trigger delay reduced and have opened cases with Apple and Jawbone. I don't expect instant progress. If you are interested in helping generate a sample of affected users, please post with

    I notice the problem = yes/no

    bluetooth device = (any, not just Jawbone)

    iPhone model =

    iOS =


    (Opened this thread so that I stopped hijacking one over here.:eek:)
  2. Squid7085 macrumors 6502a

    Aug 14, 2002
    Charlotte, NC
    I haven't actually noticed this, but what you say makes sense, I typically have music playing, but I have noticed the issue when starting the car "a few seconds before audio plays."

    I notice the problem = yes/no

    bluetooth device = Ford Sync Car

    iPhone model = iPhone 4

    iOS = 4.1
  3. Gathomblipoob macrumors 601


    Mar 18, 2009
    I've noticed this issue when using Navigon. Really frustrating.
  4. bmwhd macrumors 6502a


    May 22, 2008
    Works fine with my Motorola F505 BT handsfree kit in the car.

    iPhone 4, iOS 4.1
  5. wilsonhaven macrumors member

    Oct 12, 2009
    Noticed it with turn by turn navigation. It is so distracting that I've returned to using the speakerphone instead of the jawbone.
  6. davehutch macrumors 6502a


    Mar 5, 2009
    Croxley, Herts
    I notice the problem = yes

    bluetooth device = Sony BET2500 car radio

    iPhone model = iPhone 4

    iOS = 4.0

    Using TomTom it misses the first word of the instructions unless music is already being streamed
  7. Airmark1 macrumors regular

    Jul 26, 2008
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    Me too. It's delayed and misses the first bit of instructions if not already streaming music/podcasts.

    Tom Tom

    iPhone 4.0 on IOS 4.0

    Jawbone ICON with A2DP on.

    Obviously if on the Tom Tom cat kit itself it works fine.
  8. psywzrd macrumors 68030

    Feb 6, 2008
    I notice this problem with Navigon even when I'm not using a bluetooth device. Been that way with my 3G, my 3GS and now with my 4.
  9. fuzion11 macrumors 65816


    Sep 24, 2008
    Hamilton, Ontario
    I definitely notice that exact problem, not only when using a navigation application but also all over the OS. For instance when receiving a text message, new email alert or even unlocking/locking the phone.

    iPhone 4
    4.0.1 JB
    Blueant Q1 (using the latest firmware Blueant supports)
    TomTom app
  10. fuzion11 macrumors 65816


    Sep 24, 2008
    Hamilton, Ontario
    I'm now actually wondering if all the people using 4.1 have noticed this problem while on 4.1....or maybe they noticed it on 4.0.1 & 4.0.2 only?

    Can someone confirm that this is still happening on 4.1? I was hoping this would have been a part of the bluetooth fix that 4.1 was supposed to address.
  11. sailmac thread starter macrumors 6502


    Jan 15, 2008
    Apple says it's not the iOS -- it's the bluetooth device

    This absolutely happens on 4.1.

    Apple told me this has nothing to do with their iOS. They said it is a parameter controlled by the bluetooth device designer.

    When I asked why wouldn't all devices be designed to have zero trigger delay, they suggested one reason is so that the bluetooth device won't run out of power unnecessarily when phone buttons are pushed due to "accidental bumps while the phone is in the user's pocket or purse". If no audio content is being streamed, why keep waking up the bluetooth headset? Personally I think that is a bit of a stretch. :rolleyes: But then, I've seen many teams come up with "excessive" specs! :p

    If each bluetooth model can have a different trigger delay, then we should expect a variety of user experiences but consistency with each model. So, one thing this thread can do is help reveal which models have the lowest trigger delay. That can help MR readers when making purchase decisions. It can also provide a degree of competitive info that can be referenced when urging bluetooth headset makers to reduce their trigger delay.

    As an example, Aliph created the Jawbone ICON specifically with the iPhone in mind. According to them, it is meant to be the most iPhone-compatible headset ever. One of its better features is the ability to update firmware via the internet (MyTalk). If the trigger delay is controlled in firmware (not hardware) then it would be great if they would offer a faster trigger as an update -- either globally or as a user-selectable config. But to justify engineering effort I expect they need to see more than just a few customers are affected or care. Seeing which competitors are beating them in this area of performance may provide additional incentive to improve, too.

    In the end, if customers can't convince the bluetooth designers to make it better, then anyone who has this problem under iOS 3.x or 4.x should expect it to persist under 5.x and beyond because -- as stated above -- Apple says it is not under their control. If someone with knowledge in this area can explain it to be otherwise I'm all ears!

    Hope that helps clarifies the issue.
  12. mcclureit macrumors newbie

    May 29, 2005

    Has anyone discovered a fix for this issue? Using jailbroken 4.1, iPhone 4, Plantronics Voyager Pro+ and Navigon and am missing the first 1-2 seconds of each turn-by-turn direction.
  13. mrcalabash macrumors member

    Mar 8, 2011
    I'm having the same problem. I tried out the free map quest app because my gps was stolen. I just bought another dedicated gps because of this.

    Not to completely hijack this thread but I can't direct audio output to the car when my headset is paired with my iPhone. I wish they made a headset or phone feature where you could disable the a2dp only.
  14. Techlen macrumors newbie

    Apr 11, 2011
    I have noticed this problem from day one with my Jawbone headsets. I have owned 3 different models and they all do the same thing with all my iPhones as well. This includes the first gen. second gen. and forth gen. iPhones. All iPhones and bluetooth devices including other bluetooth devices I have owned have had this delay with missing audio at the beginning.

    I must also say that I have a droid phone that does not have a delay with any of my bluetooth devices.

    I know 100% without a doubt that it is the iPhone that has this issue. Like I said before my Droid has never had this delay issue but I have noticed that it sometimes doesn't disconnect the live feed from my bluetooth device which in turn kills my bluetooth device battery much quicker then my iPhone ever has. I am sure Apple being safe as they are, enabled this check in and out protocol to ensure maximum battery life for our bluetooth devices.

    Seems there still has to be some software issues to be worked out. I am sure this is not an easy task.

    It's just one of those things we will have to wait for unfortunately. :(
  15. clay16 macrumors newbie

    May 16, 2011
    I notice the problem = yes

    bluetooth device = Motorola Finiti

    iPhone model = iPhone4

    iOS = 4.3.3

    My issue is with turn-by-turn navigation.
    May I add that naturally I had no problem with my previous non-A2DP Moto headset.
    Since there is no way to disable A2DP in iPhone, I am basically stuck with half-instructions on my BT headset. I can of course change the output from <headset> to "iPhone" by double-clicking home button and scrolling right, but it goes back to <headset> whenever I answer a call on the BT headset.
    There's an app here that allows you to disable A2DP on a per-device basis, but it doesn't work with iOS 4.3.1 and above.
    Eagerly awaiting a fix to this one.
  16. Carminesr macrumors newbie

    Jul 11, 2011
    Bluetooth truncates audio

    I notice the problem = yes

    bluetooth device = Jawbone Icon

    iPhone model = 4

    iOS = 4.3.3

    App = Motion-X GPS

    Please add my frustration to the list.
  17. sailmac thread starter macrumors 6502


    Jan 15, 2008
    Disabling A2DP is a workaround not a solution

    Interesting. Jailbreaking and disabling A2DP might be a workaround for some people, but it does not solve the problem with trigger delay while actually using A2DP.

    My expectation (hope) is that the bluetooth device makers and Apple can consistantly interact in such a way that the trigger delay does not cut off the front end of navigation instructions. Jailbreaking should be unnecessary.

    This thread includes some combinations of bluetooth and iPhone devices that do not exhibit the problem. Seems like it should be possible for all combinations if the device makers put forth effort.

    I've wondered if the long trigger delays might be due to variability in components during assembly, although that seems like a longshot. Not enough posts in this thread to provide a trend --- for instance do all Jawbone Icon devices exhibit the problem, or just some?...
  18. clay16 macrumors newbie

    May 16, 2011
    Nevertheless a solution for some people.
    I hope a "real" solution is found soon.
  19. Gnavicks macrumors newbie

    Sep 13, 2011
    Try A2DPblocker in the App Store:

    If you have iOS 4.0 or later on your device you can use the background audio feature to keep the A2DP stream active by selecting a track from the iPod library by tapping "Background Audio" and then set the independent volume control to zero by tapping the details button, then you would not experience any delay as the iPhone is basically streaming silent audio at that point. You would need to turn off the "A2DPblocker" with the built-in switch to allow Bluetooth A2DP to connect first. The only drawback to this method is that you will need to keep the app in the foreground but I'm in the process of adding background audio multitasking for the first update if Apple approves it.
  20. danielgajdos macrumors newbie

    Jun 15, 2016
    Hi, I created an application that is solving the issue without disabling A2DP, that means it's still using A2DP profile, so you can enjoy high quality audio without the delay. I've tested it with navigation software and it works great. Please let me know if you are interested in this software as I'm considering to buy Apple developers account to release the app to the public but it costs 100$ per year, so I need to know if there is some interest in the app before I publish it. The price will be between about 5$ and you will enjoy high quality audio with no more delay. Please let me know if you are interested in the app.
  21. sailmac thread starter macrumors 6502


    Jan 15, 2008
    If I still used my old Jawbone ICON, which demonstrated the problem all the way through iOS 8.x, I might be interested in such software.

    But currently I use a Plantronics Voyager Edge and the gate triggers instantly. With it, I don't experience any lost navigation instructions, starts of song tracks, etc. It works exactly as expected. Personally at this time I have no need of a software solution since the problem no longer affects me.

    I will add this -- in the future if I encounter a BT device with the kind of audible delay described in my OP, I will return it immediately. I've come to the conclusion that some units (of any make/model) are manufacturing corner cases. They are not outright duds or DOA and may pass inspection tests, but they are not actually capable of functioning correctly. Better to replace them quickly with something that performs correctly and reliably.

    Good look with your app!
  22. ianto39 macrumors newbie


    Sep 7, 2016
    San Francisco
    I was having the same problem with my new Rowkin Bit earbuds, and was glad to find this thread. Even though it's from 2010 it's the post that comes up 1st or 2nd when googling the issue. Google Maps has resolved the problem by adding an option to use the plain Bluetooth profile instead of the A2DP profile. The option is in Settings (the 3 dots in the bottom right corner during turn-by-turn) -> Navigation Settings, then select Play as Bluetooth phone call. As soon as I did this I went from getting the last part of the direction to the full direction followed by a wurble.
  23. snowyjoey macrumors newbie

    Jan 15, 2012
    I found this thread after buying two different bluetooth radio/stereos which do this. I listen to a lot of audiobooks and the start of every SENTENCE is missing the first one or two words, totally ruins the experience so I can't use either of them :(
    I had never researched it before but my assumption was that, due to the SILENCE between sentences, the audio connection cuts briefly and cuts back in when it detects audio, which is a split second too late.
    I am using an iPhone 5s running iOS11.2, connecting to various bluetooth stereos, they all do it. Any advice, has Apple not addressed this, I noticed the thread started nearly 8 years ago!

Share This Page