Bluetooth devices keep waking iMac!!

Discussion in 'Macintosh Computers' started by adam1185, May 12, 2005.

  1. adam1185 macrumors regular

    Apr 30, 2004
    I just got my fancy new Rev. B iMac G5 today and it's great. The only problem is when I put it to sleep, my bluetooth mouse wakes it whenever the mouse moves, even though I have disabled the prefernce that allows bluetooth devices to wake the computer. There are 3 users on the machine so I disabled it in all accounts, but it still keeps waking up. Any ideas?
  2. Eniregnat macrumors 68000


    Jan 22, 2003
    In your head.
    Are you using built in Bluetooth or a USB adapter.

    All I can think is that if your using one with a USB plug the following is happening. Your Mac is keeping the USB port partly on (Mac's do this, power only- no data). The device wakes the computer (as some USB attached devices do) when movement is detected. To technically your computer is not wakening for the Bluetooth mouse, but it is actually the USB adaptor that is wakening your computer.

    That's my story and I am sticking to it.
  3. adam1185 thread starter macrumors regular

    Apr 30, 2004
    No, the iMac has built in bluetooth.

    Is there some 'global' user or something maybe that has to set whether bluetooth wakes the computer...what if you have multiple users that stay logged in and they have different settings for whether bluetooth wakes the computer or not?
  4. Sirus The Virus macrumors 6502a

    Sirus The Virus

    May 12, 2005
    A bluetooth mouse is just like a wired mouse, it behaves the same way, the only real difference is the wire missing.
  5. mobi macrumors 6502


    Jul 26, 2004
    Penn's Woods
  6. AlBDamned macrumors 68030


    Mar 14, 2005
    Yeah, surely the best way to avoid this is to just switch off the mouse after each user finishes. I know it takes a while to warm up when you switch it on to use it again, but this might be preferable to having your iMac switch on all the time. Will save your batteries too. IMO this is a compromise you have to make if you want an apple bluetooth mouse. Other wireless mice I've seen come with a dock which eliminates the problem, but I'm not sure if there is one for the Apple BT mouse. Anyone?

    P.S. The Apple BT mouse is also way too heavy!!
  7. mac-er macrumors 65816

    Apr 9, 2003
    Go to System Preferences/Bluetooth

    Uncheck the option thats says:
    Allow Bluetooth devices to wake this computer.
  8. Balin64 macrumors 6502a


    Jul 23, 2002
    In a Mauve Dream

    I have an Apple BT mouse and KB. My mouse only wakes the computer when I actually move/click the mouse or when I press a key. Does you desk transfer floor vibration? That may be enough to move your mouse, and send a signal to the Mac to wake.
  9. stevey500 macrumors 6502

    Sep 8, 2004
    Salt Lake City, Utah
    Form a mouse cover out of tin foil so the mouse can't transmit it's evil radio signals waking the imac from its rest. :D
  10. homerjward macrumors 68030


    May 11, 2004
    fig tree
    perhaps the thing about allowing bluetooth devices to wake the computer doesn't apply to mice and keyboards? i've turned it on so my phone won't wake it up, but I don't have a bt mouse or kb so i can't comment on that.
  11. Gee macrumors 65816

    Feb 27, 2004
    London, UK
    Are you sure the computer is going to sleep? There's a range of energy-saving settings (at least on my powerbook), the first of which is 'put the display to sleep'. The display can then be woken again by moving the mouse. Only when the actual computer goes to sleep do you need to click a button to wake it. Check in your energy saver settings in system preferences.
  12. AlBDamned macrumors 68030


    Mar 14, 2005
    As far as I've experienced on my powerbook and a Rev A iMac, the B/T mouse will wake the comp from sleep by just moving it agressively (ie. knocking it a couple of inches sideways when pushing a file across the desk or something). A colleague at work has the same problem with her Mac mini at home and her cat always wakes it from sleep by pushing the mouse!!

    I seriously think the best way to get around this problem if it is really bothering you is to switch just mouse off and possibly even the keyboard, whenever they are not being used, or, make a little dock for it yourself with alu-foil?!?!?!

Share This Page