bluetooth disappeared on Mac Pro 5,1 El Capitan

Discussion in 'Mac Pro' started by macmesser, Oct 24, 2016.

  1. macmesser, Oct 24, 2016
    Last edited: Oct 24, 2016

    macmesser macrumors 6502a

    Joined:
    Aug 13, 2012
    Location:
    Long Island, NY USA
    #1
    My bluetooth just disappeared. I am using a usb dongle; the internal bluetooth module went a while ago. Now bluetooth does not appear in system report and system prefs. I have been using an apple wireless keyboard and trackpad as well as bt headphones. Is it likely the dongle or system board? An old bt 2.0 dongle also doesn't appear when swapped in. It happens when booting from two system drives. USB is working. Weird that the BT prefs are gone. Is it normal that they would simply not load if the system didn't detect bt hardware on boot up? If this is so, and assuming not both of my bt dongles are busted, what other hardware (presumably on the original and still installed module) would be required for BT? Any ideas appreciated.
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Go to Apple developer page, get the BT Explore, and use the selector in there to choose (activate) your USB BT dongle.
     
  3. macmesser thread starter macrumors 6502a

    Joined:
    Aug 13, 2012
    Location:
    Long Island, NY USA
    #3

    Thanks. I've used before but didn't think to try it. Will get the latest version and try.
     
  4. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #4
    Shut down, wait, and reboot. You might want to reset SMC. Unplug, let it sit for 30 sec, replug, wait 15 sec and reboot.
    Since 10.12, I see this frequently with my internal BT.
     
  5. macmesser thread starter macrumors 6502a

    Joined:
    Aug 13, 2012
    Location:
    Long Island, NY USA
    #5
    Thanks for reply. I'm on 10.11.6. Maybe something flaky about BT implementation.
     

Share This Page