Bluetooth disappeared..

salmon06

macrumors newbie
Original poster
Aug 1, 2006
15
0
Australia
I have a 12inch powerbook 1.5ghz (Most recent of the 12inch PowerBooks) running 10.4.8. Its a very clean install (Format and re-installed last weekend).
I started using a bluetooth might mouse during the week.

Since waking my computer up from sleep I get Bluetooth: not available. Bluetooth options have all disappeared from preferences.

I have tried:
Rebooting
Unpluggin power and removing battery for 60 seconds.
Resetting nvram and restoring defaults.
Deleting the bluetooth preferences file.

If i plug in a usb bluetooth adapter it works fine.

Any ideas?

Salmon
 

salmon06

macrumors newbie
Original poster
Aug 1, 2006
15
0
Australia
Yea, i tried disk utility, repairs, reboots, PMU resets, pretty much everything relevant I could find to reset. No Luck. In the end I have just finished an archive and install which has fixed the problem. What a pain.
 

PYR0M310N

macrumors 6502a
Aug 29, 2006
543
0
had this on my G5, what you need to do is unplug everything from the back including power etc. then start your computer with on the power in and keyboard. then restart and then plug everything else back in.
 

BiikeMike

macrumors 65816
Sep 17, 2005
1,019
1
had this on my G5, what you need to do is unplug everything from the back including power etc. then start your computer with on the power in and keyboard. then restart and then plug everything else back in.
Great idea........ except its a laptop ;)

I have had this same problem on my MBP, Anyone have the answer of why this happens?
 

salmon06

macrumors newbie
Original poster
Aug 1, 2006
15
0
Australia
Ok it's gone and done it again. The trackpad also goes wierd (the speed of track sensor goes whack and slight movements become long movements).

It's still under warantee but it seems to be a software issue because an archive and install fixes the problem.

If it doesnt come good by itself i'll send it back though...what a pain.

Salmon
 

wanda

macrumors member
Aug 19, 2006
55
0
In a van down by the river
I know this thread is kinda old but I just started having the same problem...bluetooth logo has a line across it and it says "bluetooth unavailable". Its happened twice now and both times it has "fixed" itself. I did a search and came across this thread but I was wondering if there was ever any resolution to Salmon6's problem.

Any one have any idea's.

by the way, i'm using a MB C2D 1.8Gh. stock, off the shelf, no added hardware. Bluetooth device is a kensington mouse, and it's happened once with the mouse connected and once when i wasn't using any BT devices at all.
 

NicP

macrumors 6502
Jun 14, 2005
481
0
I have been having this problem a lot on my MB too. It has happened with no bluetooth devices connected, but seams to happen most often when my logitech mouse and apple keyboard are both connected.

I reinstalled 10.4 from scratch and the problem has not resolved itself
 

wetrix

macrumors 6502
Dec 1, 2006
422
0
Auckland, New Zealand
I just had the exact same problem with my C2D 2.0Ghz macbook. I searched elsewhere and found a solution that at least worked for me.

Delete /library/preferences/com.apple.Bluetooth.plist
Shutdown
Unplug everything including power
Take out battery
Leave for a few minutes
Reboot with nothing plugged in.

Bluetooth is now available.
 

resjr67

macrumors newbie
Jun 18, 2008
8
0
FINALLY! Bluetooth, Check your USB items!

Man, this has been a real pain! I have the G5 and have had this problem from the beginning. I reinstalled the ops system and it came back until I turned the system off again. I rebooted and sometimes it would come back, usually not. Finally figured it out. I had a Logitech webcam plugged into the USB which turned out to be the problem. Once I removed it and restarted, the bluetooth came back. Just to verify, I did it over and over and it kept working. I plugged in the webcam, rebooted, and it quit working. Removed, rebooted and it came back every time. ( I only rebooted so much to verify this because this system is so fast :) I tried plugging in several different USB items, and it seems things like the USB webcam and wireless components are the biggest issues. Give it a try, something about these items messes with the bluetooth card.

Hope this helps some of you,
Riley
 

wilmat09

macrumors newbie
Jul 31, 2009
1
0
Delete /library/preferences/com.apple.Bluetooth.plist
Shutdown
Unplug everything including power
Take out battery
Leave for a few minutes
Reboot with nothing plugged in.
It worked!

I was running Windows XP in Boot Camp on my MacBook (Late 2008 Aluminum) and suddenly my graphics card failed (while running Garry's Mod), forcing me to do a force-shutdown. After that my bluetooth hardware disappeared when I restarted in Windows. I tried restarting in Mac OSX and discovered the preference pane for bluetooth wasn't even there. So I tried the steps above, and it works now!

Hooray for simple fixes :apple:
 

Effedieffe

macrumors newbie
Dec 1, 2009
1
0
Delete /library/preferences/com.apple.Bluetooth.plist
Shutdown
Unplug everything including power
Take out battery
Leave for a few minutes
Reboot with nothing plugged in.
It worked for me too!

I had the same problem on my iMac G5 with Leopard and I tried the above (without the "Take out battery" item) and it works now.

Thank you guys!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.