Bluetooth Issues 15" Mid-2012

Discussion in 'MacBook Pro' started by bunnspecial, Jun 17, 2015.

  1. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #1
    I just picked up a "new"(gently used) Mid-2012 cMBP. It's currently running Yosemite(10.10.3). In any case, I tried to pair my Magic Mouse with it, and I couldn't get it to see the mouse. I know the mouse is fine, as I have zero issues pairing it with any other Mac.

    Just to test, though, I turned on Bluetooth on my iPhone(I normally keep it off) and couldn't see it either.

    I've tried cycling BT on and off as well as rebooting.

    The computer is still under Applecare so if the BT module is shot it's not a huge deal to have it fixed-I just dread a trip to the Apple Store(and time spent there that I don't have at the moment).

    Does anyone have any thoughts on other things I could try before a trip to the Genius Bar?
     
  2. bunnspecial thread starter macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #2
    Just for the heck of it, I installed Mavericks on a separate partition and got my Magic Mouse working fine. I'll tinker around with it in Yosemite some more, but at least I know the BT in the computer works.

    Besides that, I'm a lot happier using Mavericks :)
     
  3. bunnspecial thread starter macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #3
    I booted into Yoesemite again, and it decided to work. Go figure, although I'm still back to using Mavericks :)
     

Share This Page