Bluetooth Issues with Public Beta

bradbomb

macrumors 6502
Original poster
Jan 7, 2002
336
116
Los Angeles, CA
I have PB1 installed on a Late 2015 iMac 27" Retina 5k and a Magic Trackpad I have used with the system for over a year is not seen anymore by the system. Also, although the system says Bluetooth is on, I have no way of toggling bluetooth off and on as the button is greyed out. Anybody else experiencing this
 

bradbomb

macrumors 6502
Original poster
Jan 7, 2002
336
116
Los Angeles, CA
I have PB1 installed on a Late 2015 iMac 27" Retina 5k and a Magic Trackpad I have used with the system for over a year is not seen anymore by the system. Also, although the system says Bluetooth is on, I have no way of toggling bluetooth off and on as the button is greyed out. Anybody else experiencing this
I sent a report to Apple about this during version 1, PB 3 is out and still Bluetooth is not working on my iMac. Tried resetting is through the Debug menu and also boot in Safe mode. Bluetooth cannot be disabled at all either. Bluetooth was working fine in Sierra. I need to try and reinstall Sierra and see if it works again


Screen Shot 2017-07-26 at 11.48.55 AM.png
Screen Shot 2017-07-26 at 11.49.08 AM.png
 

eoblaed

macrumors 68020
Apr 21, 2010
2,404
1,806
For what it's worth, I have PB3 running on my Mac Pro, and the bluetooth is working fine (kb and trackpad). I did not have any previous High Sierra betas on this machine before installing PB3.

I'll be able to test this on my 5k iMac this weekend.
 

Hummingbird1934

macrumors newbie
Feb 24, 2008
3
0
I'm also unable to use either my Apple Wireless Keyboard or Magic Trackpad2 via Bluetooth. Submitted reports to Apple but I'm still waiting on a fix. If I boot to Sierra everything Bluetooth works normally. I'm currently having to use old USB wired devices with latest public beta of High Sierra.
 

bradbomb

macrumors 6502
Original poster
Jan 7, 2002
336
116
Los Angeles, CA
I'm also unable to use either my Apple Wireless Keyboard or Magic Trackpad2 via Bluetooth. Submitted reports to Apple but I'm still waiting on a fix. If I boot to Sierra everything Bluetooth works normally. I'm currently having to use old USB wired devices with latest public beta of High Sierra.
Are you having the same issue also where the option to Turn Off Bluetooth is greyed out? I just updated to PB4 and the issue still persists for me. Nothing Bluetooth related works including AirDrop