Bluetooth keeps enabling itself.

Discussion in 'OS X Yosemite (10.10)' started by Donka, Oct 31, 2014.

  1. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #1
    Okay, so after upgrading to Yosemite, my Mac mini turns Bluetooth on by itself even though I have it turned off. This was never an issue with Mavericks, has anyone else seen similar behaviour? It doesn't happen straight away but every time I come back to the mini after disabling Bluetooth, it is running again.

    My Mac mini is connected via HDMI to a monitor and I have a Bluetooth keyboard and trackpad for when I'm sitting at the mini itself but typically disable Bluetooth as I normally access the mini remotely and may go 2 or 3 days without actually sitting at the mini - this is why I prefer to disable Bluetooth as it helps to preserve the battery life of the keyboard and trackpad.
     
  2. tampasteve macrumors 6502

    #2
    What version Mini do you have? I have a Late 2009 A1238 Mac Mini and do not have this problem on 10.10.
     
  3. Donka thread starter macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #3
    Its the late 2012 i7 model. I'm not sure if it is to do with the keyboard and trackpad or some other setting but I didn't change anything other than update from Mavericks to Yosemite and it has been this way ever since.
     
  4. rihia macrumors newbie

    Joined:
    Oct 31, 2014
    Location:
    Brisbane, Australia
    #4
    it sounds like it has something to do with hands off or the continuity features they have released... maybe if you can disable them it may solve your issue.

    even perhaps switch it off on you iPhone if it syncs with the mini
     
  5. Donka thread starter macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #5
    I initially thought that as I had the issues with my iPhone and cars handsfree so I disabled Handoff on all my devices including my Macs but the issue remains. I also have a rMBP but I don't use BT on that and to be honest, I don't know if BT enables itself on that or not but I haven't noticed it so doubt it.
     
  6. Idgit macrumors 6502

    Idgit

    Joined:
    Mar 14, 2004
    #6
    Did you ever solve this? I have the exact same problem with my Mac Mini. It's maddening.
     
  7. Donka thread starter macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #7
    To be honest, I leave BT on all the time on the mini now because both my keyboard and trackpad have a power switch so turn them off when not in use.
     

Share This Page