Bluetooth keyboard in Bootcamp - function keys not working

Discussion in 'Windows, Linux & Others on the Mac' started by John336, Dec 29, 2012.

  1. John336 macrumors newbie

    Joined:
    Jun 19, 2011
    #1
    Any ideas?

    When I am in bootcamp (Windows 7) my bluetooth keyboard function keys do not work. If I plug a usb Apple keyboard, function keys work as they should. Screen brightness, play/pause, volume, etc. I am still on OS 10.6.8 on the Mac side. So I am running bootcamp 3.3, as a result.

    I have done all of the standard things that I know of. Remove the keyboard completely, then pair again. Do all system updates on Mac and Windows. I even reset the PRAM, no success.

    Any ideas at all would be appreciated.

    Thanks,

    John
     
  2. pure3d2 macrumors 6502

    Joined:
    Mar 7, 2012
    #2
    I take it that you installed the bootcamp drivers while in windows? When you used the bootcamp assistant, it should have asked you to save the drivers into a USB flash drive or somewhere on your computer. The folder is named WindowsSupport.

    If you have the bootcamp drivers installed, open up the bootcamp control panel and take a look at the keyboard tab:

    [​IMG]

    When that box is checked, the function (F1, F2, F3, etc) keys will work when you press them (e.g. pressing F5 will reload a web page). When you hold down the Fn key and then press one of the F keys (like Fn+F1), that will turn the brightness down.
     
  3. John336 thread starter macrumors newbie

    Joined:
    Jun 19, 2011
    #3
    Thanks. That is something I forgot to mention. I installed the drivers and made sure they were all updated. The bootcamp control panel checkbox, that you mentioned, is unchecked. I have tried it both ways, just to see, but even with it unchecked the specialty functions don't work.

    A few other things that I should mention. They keyboard on my MacBook pro works no problem. It is only my bluetooth keyboard that I am pairing with it, has the issues.

    Also, I went into OSX and renamed my keyboard, and totally removed it from the OSX side. Still no joy.

    Thanks for the help!
     

Share This Page