Bluetooth keyboard not working correctly

Discussion in 'OS X Yosemite (10.10)' started by BrandoFiasco, Jun 18, 2015.

  1. BrandoFiasco macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #1
    My boss' 2012 iMac is on 10.10.3

    His bluetooth keyboard is not responding correctly to the function keys (e.g. volume, dashboard, brightness, etc.) In addition, the 'Use all F1, F2, etc. keys as standard keys' is missing in the keyboard settings under System Preferences.

    When I plugin my wired keyboard all the keys work as expected, which leads me to think its a bluetooth driver issue. Is there a file I can replace or somehow fix this? Thanks!
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    Is this a 3rd party BT keyboard?
    In my experience the keyboard pref pane only shows correctly when using an Apple keyboard.
     
  3. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #3
    No its an Apple keyboard :(
     
  4. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
  5. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #5
    Yea i tried that. Still wouldnt explain the missing function check box in system preferences though.
     
  6. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #6
    I did an install over the current install and that fixed the issues. I'm always weary of doing that but it worked perfectly.
     
  7. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #7
    It now stopped again on 10.10.3, i tried updating it to 10.10.4 but even after the update it still just ceases. Any help is appreciated.
     
  8. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #8
    Is your Boss using any USB3 equipment? I ask because there are many reports of problems between BT and USB3.
     
  9. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #9
    No he's not, its literally just the iMac and his keyboard nothing fancy. Its so frustrating!
     
  10. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #10
    Create a new user account, reboot and login to the new user account. Does the issue happen in the new user account?
     
  11. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #11
    Ugh. I tried this, its almost worse, it goes to sleep and then wont wake up at all, not even to wired mouse clicks. Im thinking I should do a clean install and then migrate the apps and files over, but not the settings...see if that works.
     
  12. barbu macrumors regular

    barbu

    Joined:
    Jul 8, 2013
    Location:
    ott.on.ca
    #12
    wary ;-)

    I imagine you have tried un-pairing/re-pairing? Have you tried it with a different machine? What if you plug in a standard USB keyboard, does it appear then?
     
  13. BrandoFiasco thread starter macrumors member

    Joined:
    Jan 28, 2011
    Location:
    Santa Monica, California
    #13
    ha! Thanks for the correction. Yea I did try on a different machine, and usb keyboard works fine immediately. I just installed 10.10.5 over it, lets see if that helps at all...
     

Share This Page