Bluetooth Keyboard "sleeps" in Windows 7

Discussion in 'Windows, Linux & Others on the Mac' started by compulsiveguile, Aug 30, 2009.

  1. compulsiveguile macrumors newbie

    Joined:
    Feb 9, 2008
    Location:
    OH
    #1
    I finally got my Bluetooth keyboard to sync (http://forums.macrumors.com/showthread.php?t=630024) with my MacBook Pro (Snow Leopard, Boot Camp 3.0), but I'm having one slight issue...

    My keyboard seems to sleep/go unresponsive after like 10 seconds. Once I start typing again, it initially doesn't work. After 2-3 seconds it picks up again. I read at the end of the thread I listed above that there might be a power setting somewhere?

    I tried to follow those instructions, but that particular check box wasn't selected (it was actually grayed out)... so perhaps it's a different issue?Anyone have a solution to this? Kinda driving me crazy...

    Thanks in advance!
     
  2. Snakehn macrumors newbie

    Joined:
    Aug 18, 2009
    #2
    i was having the same issue and had to pair the keyboard several times, and then found the workaround you quoted, it worked just fine, now i am wondering why would yours be grayed out, sure it was a pain in the butt here.
     
  3. compulsiveguile thread starter macrumors newbie

    Joined:
    Feb 9, 2008
    Location:
    OH
    #3
    So checking/unchecking some box related to power management did it for you?
     
  4. compulsiveguile thread starter macrumors newbie

    Joined:
    Feb 9, 2008
    Location:
    OH
    #4
    Ah ha! I found the solution.

    Gees... Windows 7 Bluetooth settings and menus sure are cryptic. I wonder if Microsoft could have possibly layered them anymore. :) Also, I suppose it should be noted that Apple seems to have this checked on default. This should definitely be changed. Anyhoooo....

    My solution:
    Go to Bluetooth Devices (click the Bluetooth notification icon in the dock... err... taskbar) -> Open Settings.

    Now click the Hardware tab, select Apple Built-in Bluetooth, and click Properties in the bottom right. A new window should pop up.

    Click "Change settings" in the lower left (shield icon).

    The window closes and a slightly different one opens. Go to the Power Management Tab and uncheck "Allow the computer to turn off this device to save power."

    Oooo... it's like magic.
     

Share This Page