Bluetooth missing

Discussion in 'Mac Basics and Help' started by allanj37, Oct 5, 2007.

  1. allanj37 macrumors newbie

    Joined:
    Oct 5, 2007
    #1
    I've got a powerbook, and I'm having the issue of my computer not realizing it has bluetooth (built in). I've read a bunch of other threads of people with this issue, so it seems like a fairly common problem.

    Summary of the problem:
    I got my computer about two years ago, and bluetooth worked for about a day. I haven't had any bluetooth devices until now, so I've never worried about fixing it too much. I don't have a bluetooth icon in my menu bar, the system preference pane doesn't show up, and the system profiler says I don't have a bluetooth device (under bluetooth or usb).

    Fixes I've tried:
    I've had the computer for a couple years, so restarting is obviously not going to magically fix it.
    Bluetooth firmware update - won't run because it says I don't have bluetooth hardware.
    I deleted the bluetooth plist files from both my home directory and from root's.
    I reset the pram.
    I did a reset-all from the open firmware.
    I reset the pmu.
    I've unplugged everything, taken the battery out for 10 min, and then started it back up.

    I haven't reinstalled the OS because I don't have my install disc any more. Can anyone think of anything else to try, or am I just SOL?

    Thanks!
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #2
    open it up and check that the bluetooth adapter is connected/seated and the antenna isn't disconnected?
     
  3. georgi0 macrumors regular

    georgi0

    Joined:
    Aug 21, 2006
    Location:
    Cyberspace
    #3
    i have a similar problem.
    they only way to have my bluetooth enabled is when i turn off the computer completly for 2-3 hours or more without doing any stand by or hybernate.

    Then for some magical reason the blue tooth is there till i close the cover (stand by) and then when i reopen it disappears.

    So there is no connection proble, it should be software.

    I bored to take it to the store ( i have another month of warranty) and i have not reinstalled the OS again either.

    ny more ideas (assuming i have already done all the above steps you mentioned correctly)

    :)
     

Share This Page