Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

loadedmind

macrumors newbie
Original poster
Oct 8, 2009
6
0
Planet Earth
This one is a bit strange. First, hardware specs:
Mac Pro Mid 2010 12-core w/ 16GB RAM running 10.11.6
Bluetooth headset (https://www.amazon.com/gp/product/B017H4LSN4/ref=oh_aui_search_detailpage?ie=UTF8&psc=1)

While playing YouTube videos, only mono output, not stereo. However, if I open Sound Preferences, sound magically changes from Mono to Stereo, without modifying any settings. :rolleyes: Anyone have a suggestion? It only started doing this a few weeks ago.
 

Jesla

macrumors 6502a
Jan 7, 2013
541
170
Tennessee USA
Pram Reset

Here's how to reset your PRAM:
  1. Shut down your machine. Yes, all the way down, not sleep or logging out.
  2. Press the power button and then press command-option-p-r. ...
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.
 

loadedmind

macrumors newbie
Original poster
Oct 8, 2009
6
0
Planet Earth
I did this twice last Thursday. I'll do it again just for good measure and report back results. Also repaired permissions a few times last week too. Thanks for your reply.
 

ActionableMango

macrumors G3
Sep 21, 2010
9,612
6,907
Bluetooth has many protocols that it can use to connect with a device. Headsets typically connect with two protocols:
  • HSP (headset profile) which has low latency, one speaker (mono), and one mic. This is meant for 2-way communication.
  • A2DP which gives up the mic for two speakers (stereo) and higher quality. This is meant for stereo audio output.
Probably your headset has connected with both profiles, but the HSP as default. I haven't had this happen on my Mac, but I have experienced the problem in my car. The fix was blowing away all bluetooth settings/pairings/etc and pairing again as new.

If you want to completely reset all bluetooth settings, hold down SHIFT-OPTION while clicking on the bluetooth icon in the menu bar. You'll see a debug menu which has some reset and remove options. But ignore that for now and click on the headset. Now it should have some remove/reset options.

Try that first before going to the debug menu. The debug menu blows away all bluetooth devices, so you would have to pair all of your bluetooth devices again.
 
  • Like
Reactions: Snow Tiger

loadedmind

macrumors newbie
Original poster
Oct 8, 2009
6
0
Planet Earth
Jesla> Thanks for your reply and info. I reset the PRAM and no joy.

ActionableMango> I first tried your suggestion to reset the Bluetooth device, then re-paired it and no joy. I then reset all Bluetooth and rebooted. Still no joy. What's so very strange is that if I bring up System Preferences->Sound, the sound goes stereo. If I leave that window open, it stays that way. The minute I close it down, it goes back to Mono after 1 or 2 seconds.
 

Jonescifer

Cancelled
Jul 11, 2017
3
1
If anyone is looking for an answer yet.. change the "input" in "Sound Settings" from your bluetooth headphones to Built-In... (crazy right?)

many thanks to linesarefuzzy on superuser for the fix:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.