Bluetooth Mouse Issue on the MBA

Discussion in 'MacBook Air' started by macanudo, Mar 1, 2008.

  1. macanudo macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #1
    I purchased an apple bluetooth mouse last week for my MBA and it has been working great up until this morning. I went to use it and I have much delayed feedback in my mouse movements. Here are the things I tried:

    1. Paired it with another mac w/bluetooth and it works normally.
    2. Replaced the batteries on the bluetooth mouse, same issue.
    3. Repaired the mouse with the MBA, same issue.
    4. Changed the wireless channel on my airport express to 8.

    Any suggestions?
     
  2. anarchron macrumors member

    Joined:
    Aug 7, 2004
    #2
    Yeah, mine does that too. For some unknown reason, it works perfectly fine with my 20" iMac, but lags occasionally on my MBA.
     
  3. macanudo thread starter macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #3
    Thanks for the input. Funny thing is that it just started doing it today...and it was working fine for about a week and a half, no problems. Have you had any luck fixing it?
     
  4. mcvaughan macrumors 6502

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #4
    I see this occasionally with mine, but I use mine with my MBP. I can typically just turn off the mouse and turn it back on to resolve it. If not, I turn off bluetooth and flip it back on.
     
  5. macanudo thread starter macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #5
    Yeah, unfortunately I've tried that too. I going to break out my old MS crappy bluetooth mouse to see if that has no lag...
     
  6. macanudo thread starter macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #6
    So here's an update -

    I tried the BT mouse on my pro at work today (which has a D-Link USB BT adapter) and it works flawlessly. I then plug in the D-link USB BT adapter into my MBA, works flawlessly. Unplug the D-Link, then it goes back to the annoying lagtime with the MBA's built in bluetooth.

    Reset the PRAM too, nothing.

    I've already scheduled a apple store genius bar appt.
     
  7. ProPedderKustom macrumors regular

    Joined:
    Jan 11, 2008
    #7
    Are you running the MBA in closed lid mode? I have my MBA hooked up to my 52" HDTV with Apple BT keyboard and mouse. If the MBA is closed when I'm using it, it has a tendency to lag. If it really bothers you, open the computer up...I think it has something to do with the metal case being closed and interfering with the BT radio connection.
     
  8. macanudo thread starter macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #8
    I experience this both during lid closed and regular usage.
     
  9. macanudo thread starter macrumors regular

    macanudo

    Joined:
    May 9, 2006
    Location:
    Philadelphia, PA
    #9
    All is right in the world!!! :D

    Because of my bluetooth mouse lagging problem, the Apple Store deemed my 13 day old MBA defective and gave me a shiny new one! No bluetooth problems yet :eek:
     

Share This Page