Bluetooth Mouse problem

Discussion in 'MacBook Pro' started by Eric8199, Jul 19, 2009.

  1. Eric8199 macrumors 6502a

    Joined:
    Feb 27, 2009
    #1
    Alright, so I'm about ready to throw my mouse through the wall.

    Last November I bought a unibody MacBook Pro. I've been using a PowerBook G4 at work. I had a Targus Bluetooth Mouse that I was using on my work computer, and had no problems whatsoever. I went back to a corded mouse on that computer and moved the bluetooth to my new MBP.

    But I have a problem. Occassionally, the mouse will become jumpy. It's not terrible, but it's annoying. I do layout and photoshop work, so it can REALLY make things difficult when it happens.

    I thought maybe it was the mouse, so today I went and spent $70 on a bluetooth Apple Mighty Mouse. Mistake. It's 10 times worse. It's CONSTANTLY jumping around. As I move the cursor, it will suddenly jump like two to three inches in a random direction. it's almost impossible to position where I want it. I really would prefer the mighty mouse, but don't want to use up a USB port for a mouse.

    Anyone else having this problem? Going to try the Mighty Mouse with my PowerBook at work tomorrow and see if it does it there too, but I doubt it will.
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    I had a similar problem with my Logitech v470, but I never figured it out.
     
  3. fpnc macrumors 68000

    Joined:
    Oct 30, 2002
    Location:
    San Diego, CA
    #3
    IMO, if you're using Photoshop or any application that requires precise mouse control you shouldn't be using Bluetooth. For precise, dependable control wired mice are still the best option, next would be any of the RF mice, and last by a significant margin would be Bluetooth. Of course YMMV, but generally it's just easier to avoid the "problem" rather than trying to find a workable Bluetooth solution.
     
  4. djinn macrumors 68000

    djinn

    Joined:
    Oct 4, 2003
    #4
    Is your wireless on? If it is, change the Channel. I had a similar problem with my BT and wireless, changed the channel on my wireless router and all is well.
     

Share This Page